Preface

Product Version

The following table lists the product versions relevant to this document.

Product Name | Product Version
SingleFAN | V100R017C10
OLT | V800R017C10
ONT | V300R017C10
U2000 | V200R016C60

Intended Audience

This document mainly describes the characteristics, auxiliary devices, and networking, services and planning of the FTTB/C solution.

The intended audience of this product description are as follows:

  • Network planning engineers
  • Installation and commissioning engineers
  • Field maintenance engineers
  • Network monitoring engineers
  • System maintenance engineers
  • Data configuration engineers

Symbol Conventions

The symbols that may be found in this document are defined as follows.

Symbol | Description
 | Indicates an imminently hazardous situation which, if not avoided, will result in death or serious injury.
 | Indicates a potentially hazardous situation which, if not avoided, could result in death or serious injury.
 | Indicates a potentially hazardous situation which, if not avoided, may result in minor or moderate injury.
 | Indicates a potentially hazardous situation which, if not avoided, could result in equipment damage, data loss, performance deterioration, or unanticipated results. NOTICE is used to address practices not related to personal injury.
 | Calls attention to important information, best practices and tips. NOTE is used to address information not related to personal injury, equipment damage, and environment deterioration.

Change History

Updates between document versions are cumulative. Therefore, the latest issue contains all updates made in previous issues.

Updates in Issue 02 (2017-01-06)

This issue is the second official release. Based on issue 01 (2016-05-30), the document is updated as follows:

Matched with FTTx V100R017C10 and updated the matched ONT web page configurations.

Updates in Issue 01 (2016-05-30)

The FTTx V100R017C00 is officially released for the first time.

Huawei Proprietary and Confidential Copyright © Huawei Technologies Co., Ltd.
Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.


FTTH Networking and Configuration Scenarios

Typical FTTH Networking

Figure 1 shows the typical FTTH networking.

Figure 1 Typical FTTH networking diagram

Networking Scenario

Description

Bridging ONT + HGW Network Scenario

The HGW integrating an IAD provides Internet, voice over Internet Protocol (VoIP), and Internet Protocol television (IPTV) services to users.

Services are implemented on the HGW, and the bridging ONT works with the OLT to provide Layer 2 channels.

Bridging+Voice ONT Network Scenario

The ONT integrating an integrated access device (IAD) provides Internet, VoIP, and IPTV services to users.

The bridging+voice ONT provides Layer 2 data and voice services. This scenario provides transparent transmission channels and requires simple service configuration, so this scenario applies to Layer 2 networking.

  • For data services, a PC directly performs dial-up. Then, the upper-layer broadband remote access server (BRAS) device authenticates and accesses the PC. The PC can also access the Internet using the Dynamic Host Configuration Protocol (DHCP) or static IP address.
  • The ONT with a built-in voice module encapsulates voice service packets, and the OLT transmits them to the upstream next generation network (NGN) or IP multimedia subsystem (IMS).

Gateway ONT Network Scenario

The ONT integrating an IAD provides Internet, VoIP, and IPTV services to users.

The HGW ONT facilitates interconnection of home devices by providing Layer 3 services, such as Point-to-Point Protocol over Ethernet (PPPoE)/DHCP dial-up, network address translation (NAT), and Internet Group Management Protocol (IGMP) snooping. This scenario provides fine-grained management channels and service control, and applies to Layer 3 networking.

FTTH Deployment Schemes

FTTH service application includes the deployment process and service provisioning process. The FTTH deployment process includes OLT deployment (configuration) and configuration of basic data. No deployment, however, is required on the ONT and the ONT is plug and play once services are provisioned.

Table 1 lists the FTTH deployment schemes and service provisioning methods.

Table 1 FTTH deployment schemes

Scheme

Parameter

Pre-configuration
  • On the NMS: Profiles can be issued in batches.
  • Using commands on the OLT: Configuration scripts containing commands can be imported to the OLT.
  • DBA profile
  • Line profile
  • Service profile
  • IP traffic profile
  • Service level profile
  • Global OLT configurations (rather than FTTH user configurations) such as multicast VLAN, multicast mode, and policy of forwarding unknown packets
  • FTTH user service VLAN configurations including adding VLANs, setting the attributes of VLANs, and adding upstream ports for VLANs

Service Provisioning
  • Using the OSS: This method is recommended and it can implement automatic service provisioning, and eliminate problems caused by manual service provisioning, such as large workload, low efficiency, and difficult management.
  • Using OSS+ITMS: This method is recommended if the multiple private nodes are customized for carriers. Using a TR069 server, new gateways and value-added voice services can be simply added.
    • Layer 2 configuration data is issued on the NMS or OLT.
    • Other configuration data such as voice, Layer 3, and Wi-Fi data is issued using the ITMS.
  • On the NMS: It applies to the scenario when no OSS is available and services need to be provisioned manually on the NMS.
  • On the ONT web page: When it is not feasible to provision services on the OSS or NMS, you can log in to the ONT web page and configure or modify parameters to provision services.

See Table 2.

ONT service provisioning parameters are classified into common parameters and customized parameters:
  • Customized parameters are usually issued by the upper-layer system during service provisioning.
  • Common parameters are usually configured at delivery or during data pre-configuration.
Table 2 Parameters required for ONT service provisioning

Parameter Type

Layer 2

Voice

Above Layer 2 (Layer 3, Wi-Fi, and User Security)

Customized parameters

Parameters for adding ONTs, adding service flows, activating ports, configuring port rate limitation, and adding multicast users
  • Registration information: IP address and port number of the local end and the proxy
  • User data: SIP user name and H.248 TID

Login user name and password

Common parameters

Various pre-configured profile data
  • Digitmap: includes the digitmap timer and digitmap character strings.
  • Time configuration: includes registration heartbeat and protocol timers.
  • Encoding and decoding: includes voice encoding and decoding priorities and packetization period, G.711/G.729/G.722.
  • Fax/Modem.
  • Service permission and service data.
  • VAG: implements multiple virtual AG devices on one physical device.
  • Configurations for the interconnection between IMSs of softswitches of different specifications.
  • WAN port configurations (routes, bridge WANs, and VLANs)
  • LAN/WAN binding
  • IGMP mode
  • URL for the ITMS
  • NTP server
  • Default Wi-Fi configurations
  • Local login IP address

ONT type
  • Bridging ONTs (SFUs)
  • Bridging+voice ONTs
  • Gateway-type ONTs (HGUs)
  • Bridging+voice ONTs.
  • Gateway-type ONTs.

Gateway-type ONTs
The following describes the involved configuration scenarios:
  • Service configuration on the NMS: Pre-configurations and service provisioning are implemented on the NMS.
  • Service configuration using commands: Pre-configurations are implemented using commands, and service provisioning is implemented on the ONT web pages.
  • Service provisioning on the ITMS: Pre-configurations are implemented on the NMS or using commands, and Layer 3 and voice services are provisioned on the ITMS. Huawei U2560 is used as an example to describe how to provision the services on the ITMS.


Principle of FTTH Data Plan

    Data Plan Principles for IP Addresses
    This section describes how to obtain an IP address in various scenarios.
    Principle of QoS Planning
    The QoS planning is an E2E planning, and it can be divided into following policies: traffic classification, marking, and scheduling policy; and traffic monitoring and DBA policy.
    Principles of Internet and Wi-Fi Access Services Data Planning
    This topic describes the principles of data planning for Internet and Wi-Fi access services and will focus on the VLAN planning and VLAN translation policy planning in different network scenarios.
    Principle of Voice Service Data Plan
    The voice service plan mainly includes the plan of the VLAN and VLAN translation policy in different network scenarios, and the plan of voice protocol.
    Principle of IPTV Service Data Plan
    The IPTV service data plan mainly include the plan of VLAN and VLAN translation policy in different network scenario, and the plan of IPTV service.
    Principle of Security Data Plan
    The security plan involves system security plan, user security plan, and service security plan. Security policy ensures service security from different aspects.


Data Plan Principles for IP Addresses

This section describes how to obtain an IP address in various scenarios.

Terminal Type

Service

Recommended Solution

Bridging+Voice ONT

Internet access

A PC obtains an IP address through PPPoE dialup. The ONT transparently transmits the packets.

VoIP

The ONT functions as a DHCP client and obtains an IP address from the DHCP server, or the NMS issues a static IP address to the ONT using the configuration file. Voice signaling and media streams at multiple POTS ports share one IP address. Media streams are distinguished by port.

IPTV

The set top box (STB) obtains an IP address from the DHCP server for ordering programs. The ONT transparently transmits the packets.

Bridging ONT+HGW

Internet access

The HGW functions as a PPPoE client and obtains an IP address through PPPoE dialup. At the same time, the HGW functions as a DHCP server and allocates IP addresses to PCs through the network cable and wireless fidelity (Wi-Fi) access. The ONT transparently transmits the packets.

VoIP

The HGW functions as a DHCP client and obtains an IP address from the DHCP server, or the application control server (ACS) issues a static IP address to the HGW using TR069. Voice signaling and media streams at multiple POTS ports share one IP address. Media streams are distinguished by port. The ONT transparently transmits the packets.

IPTV

The HGW is configured with a bridging WAN port. The STB obtains an IP address from the DHCP server. The HGW transparently transmits packets. The ONT also transparently transmits the packets.

Gateway ONT

Internet access

The HGW functions as a PPPoE client and obtains an IP address through PPPoE dialup. The ONT functions as a DHCP server and allocates IP addresses to PCs through the network cable.

Wi-Fi access
  • Layer 3 bridge Wi-Fi access service: A mobile equipment (ME) searches the SSID. After the ME is authenticated, the DHCP server assigns this ME the IP address by IPoE.
  • Layer 3 route Wi-Fi access service: An ME searches the SSID. After the ME is authenticated, the DHCP address pool of an ONT assigns this ME the IP address and then PPPoE dialup is automatically performed on the ONT.

VoIP

The ONT functions as a DHCP client and obtains an IP address from the DHCP server, or the NMS issues a static IP address to the ONT using the configuration file. Voice signaling and media streams at multiple POTS ports share one IP address. Media streams are distinguished by port.

IPTV

The ONT functions as a DHCP client and obtains an IP address from the DHCP server. At the same time, the ONT functions as a DHCP server and allocates IP addresses to STBs.
Parent Topic: Principle of FTTH Data Plan
Huawei Proprietary and Confidential Copyright © Huawei Technologies Co., Ltd.
Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.
Next topic >


Principle of QoS Planning

The QoS planning is an E2E planning, and it can be divided into following policies: traffic classification, marking, and scheduling policy; and traffic monitoring and DBA policy.

Traffic Classification, Marking, and Scheduling Policy

Service Type | 802.1p Priority | Queue Scheduling Method | OLT Queue ID (8 Queues) | ONT Queue.ID
 |  |  |  | When Eight Queues Are Supported | When Four Queues Are Supported
Management service | 6 | PQ | 6 | 6 | 3
VoIP service | 5 | PQ | 5 | 5 | 2
IPTV service | 4 | PQ | 4 | 4 | 2
Wi-Fi access service | 1 | PQ | 1 | 1 | 1
Internet access service | 0 | PQ | 0 | 0 | 0
NOTE:
The greater the priority value, the higher the priority. The service priorities in this table are the recommended values. The service priorities are arranged according to the operators's actual plan.

Traffic Monitoring and DBA Policy

Items | Management service | Internet access service | Wi-Fi access service | VoIP service | IPTV service
GEM port | 11 [Remark 1] | 14 | 15 | 12 | 13
TCONT | Select a DBA type based on service types. For example, select Type1 for the management service, Type4 for the Internet access service, and Type2 for the VoIP and IPTV services.
DBA type | Type 3 (DBA profile: assured bandwidth + maximum bandwidth. Users are allowed to preempt the bandwidth on condition that the users' assured bandwidth is guaranteed. However, the total bandwidth cannot exceed the maximum bandwidth.)
DBA bandwidth planning | Configure the DBA bandwidth according to the user's bandwidth package. The assured bandwidth is the maximum bandwidth required by management packets, VoIP, and IPTV upstream packets. The maximum bandwidth is larger than or equal to the maximum bandwidth that users apply.
Rate limit on OLT downstream | No rate limit | Configure rate limit by a traffic profile as required. [Remark 2] | Configure rate limit by a traffic profile as required. [Remark 2] | No rate limit | No rate limit
Rate limit on ONU upstream port | No rate restriction
Rate limit on ONU downstream port | No rate restriction

Remark 1: GEM port value depends on the planning of the service provider, but in principle, use different GEM ports for different services.

Remark 2: Table 1 shows the reference service bandwidth of each service for each user.
Table 1 Reference service bandwidth of each service for each user
Service Type | Upstream Bandwidth | Downstream Bandwidth | Bandwidth Description
Internet access service/Wi—Fi access service | Determined based on the service tariff package. | Determined based on the service tariff package. | Available bandwidth of Internet access service or Wi—Fi access service = Committed bandwidth of the service tariff package - VoIP bandwidth - IPTV bandwidth
VoIP service | 200 kbit/s | 200 kbit/s | The upstream bandwidth and the downstream bandwidth of VoIP service are symmetrical. The actual bandwidth is related to the coding format. This bandwidth is calculated for two POTS ports.
IPTV service (standard definition program) | N/A | 2.5 Mbit/s per channel | IPTV service mainly occupies the downstream bandwidth. The actual bandwidth depends on the coding format, the picture in picture information, 10% bandwidth burst traffic, and the number of programs that can be concurrently watched by one user (in the case of multiple STBs). The upstream bandwidth is mainly used for transmitting IGMP packets, which requires little bandwidth. Therefore, the bandwidth occupied by IGMP packets can be neglected.
IPTV service (high definition program) | N/A | 9.7 Mbit/s per channel
NOTE:
  • The rate restriction on the BRAS or SR is recommended. OLTs and ONTs do not restrict the rate for service streams.
  • If BRAS does not support rate restriction, OLTs can restrict the rate for service streams through the traffic profile.
  • Different service packets on the ONT are distinguished by different VLAN IDs. The service packets are mapped to GEM ports based on VLAN IDs so that different service packets are transmitted to different GEM ports. Each GEM port (each service) corresponds to a T-CONT or all GEM ports share a T-CONT.
  • The sum of the assured bandwidth of all ONTs connected to a PON port and the fixed bandwidth of OMCI management channel is less than the GPON upstream bandwidth. Some bandwidth must be reserved for the future service expansion.
Parent Topic: Principle of FTTH Data Plan


Principles of Internet and Wi-Fi Access Services Data Planning

This topic describes the principles of data planning for Internet and Wi-Fi access services and will focus on the VLAN planning and VLAN translation policy planning in different network scenarios.

Table 1 Planning of VLANs and VLAN translation policies for Internet access service
Application Scenario | VLAN Plan | VLAN Translation Policy
Bridging+Voice ONT | Double-tagged VLAN | ONT: ONTs configure the VLAN and add the same C-VLAN tag to packets. All ONTs are in the same C-VLAN. OLT: The OLT performs VLAN translation: C<->S+C'. The C'-VLAN of every ONT differs from each other.
Bridging ONT + HGW | Double-tagged VLAN | ONT: The upstream packets sent from the HGW carry user-VLANs and the ONT transparently transmits them. OLT: The OLT translates the U-VLAN to S-VLAN+C-VLAN.
Gateway ONT | Double-tagged VLAN | ONT: ONTs configure the VLAN and add the same C-VLAN tag to packets. All ONTs are in the same C-VLAN. OLT: The OLT performs VLAN translation: C<->S+C'. The C'-VLAN of every ONT differs from each other.
Table 2 Planning of VLANs and VLAN translation policies for Wi-Fi access service
Application Scenario | VLAN Plan | VLAN Translation Policy
Gateway ONT | Single-tagged VLAN | ONT: ONTs configure the VLAN and add the same C-VLAN tag to packets. All ONTs are in the same C-VLAN. OLT: The OLT performs VLAN translation: C<->S.
Note:
  • User VLAN: VLAN carried by packets going upstream from user-side devices (such as a home gateway), U-VLAN for short.
  • C-VLAN: VLAN added based on the ONT/ONU port. For details, see the description of the Double-tagged VLAN S+C.
  • Double-tagged VLAN S+C: C indicates the inner VLAN (C-VLAN) and S indicates the outer VLAN (S-VLAN).
  • Double-tagged VLAN S+C': C' indicates the translated inner VLAN (C'-VLAN) and S indicates the outer VLAN (S-VLAN).
  • Single-tagged S-VLAN: Single-tagged VLAN marked or translated by the OLT. It is generally used in a single-tagged VLAN translation scenario.
  • C<->S+C': Bidirectional VLAN translation: translates the C-VLAN and then adds an S-VLAN.
  • C<->S+C: Bidirectional VLAN translation: maintains the C-VLAN and adds an S-VLAN.
NOTE:
  • To ensure traceability of users and finer-grained QoS control and management of users and services, plan per user per service per VLAN (PUPSPV) for the Internet access service. Considering OLT capacity and VLAN scalability, use dual VLANs (S-VLAN+C-VLAN) on the OLT to differentiate users for the Internet access service.
  • The outer VLAN (S-VLAN), which identifies services and physical location, can be allocated based on the OLT, PON board, or PON port. The inner VLAN (C-VLAN) identifies users. C-VLANs must be unique in one S-VLAN.
  • It is recommended that you use stacking VLANs as S-VLANs so that security features, such as PPPoE+/option82, and anti-MAC attacks and anti-MAC spoofing, can be easily deployed.
  • The 802.1q in 802.1q (QinQ) VLAN is used in the enterprise private line scenario, such as transparent LAN service (TLS), in which the device transparently transmits packets. It is not recommended that you use QinQ VLANs as S-VLANs for the triple play services of residential users.
Parent Topic: Principle of FTTH Data Plan


Principle of Voice Service Data Plan

The voice service plan mainly includes the plan of the VLAN and VLAN translation policy in different network scenarios, and the plan of voice protocol.

VLAN and VLAN Translation Policy

Application Scenario | VLAN Plan | VLAN Translation Policy
Bridging+voice ONT | Single-tagged VLAN (recommended) | ONT: VLANs are configured for the ONTs on the same network in a unified manner, and the ONTs have the same C-VLAN. The ONT adds a C-VLAN tag to packets. OLT: transparently transmits the VLAN.
 | Double-tagged VLAN | ONT: VLANs are configured for the ONTs on the same network in a unified manner, and the ONTs have the same C-VLAN. The ONT adds a C-VLAN tag to packets. OLT: adds an S-VLAN tag to the packets (C-VLAN <-> S-VLAN+C-VLAN).
 | Double-tagged VLAN | ONT: VLANs are configured for the ONTs on the same network in a unified manner, and the ONTs have different C-VLANs. The ONT adds a C-VLAN tag to packets. OLT: adds an S-VLAN tag to the packets (C-VLAN <-> S-VLAN+C-VLAN).
Bridging ONT+HGW | Single-tagged VLAN (recommended) | ONT: Packets that are sent upstream by the HGW are tagged with a user VLAN. The ONT transparently transmits the user VLAN. OLT: translates the VLAN tag (user VLAN <-> S-VLAN).
 | Single-tagged VLAN | ONT: Packets that are sent upstream by the HGW are tagged with a user VLAN. The ONT translates the user VLAN (user VLAN <-> S-VLAN). All the ONTs connected to the same OLT have the same voice service S-VLAN; ONTs connected to different OLTs may have different voice service S-VLANs. OLT: transparently transmits the VLAN.
 | Double-tagged VLAN | ONT: Packets that are sent upstream by the HGW are tagged with a user VLAN. The ONT transparently transmits the user VLAN. OLT: translates the VLAN tag (user VLAN <-> S-VLAN+C-VLAN).
 | Double-tagged VLAN | ONT: Packets that are sent upstream by the HGW are tagged with a user VLAN. The ONT translates the user VLAN (user VLAN <-> C-VLAN). The C-VLAN is an inner VLAN tag that differentiates users. OLT: adds an S-VLAN tag to the packets (C-VLAN <-> S-VLAN+C-VLAN).
Gateway ONT | Single-tagged VLAN (recommended) | ONT: VLANs are configured for the ONTs on the same network in a unified manner, and the ONTs have the same C-VLAN. The ONT adds a C-VLAN tag to packets. OLT: translates the VLAN tag (C-VLAN <-> S-VLAN).
 | Single-tagged VLAN | ONT: VLANs are configured for the ONTs on the same network in a unified manner, and the ONTs have the same C-VLAN. The ONT adds a C-VLAN tag to packets. OLT: transparently transmits the VLAN.
 | Double-tagged VLAN | ONT: VLANs are configured for the ONTs on the same network in a unified manner, and the ONTs have the same C-VLAN. The ONT adds a C-VLAN tag to packets. OLT: translates the VLAN tag (C-VLAN <-> S-VLAN+C-VLAN').
Note:
  • User VLAN: VLAN carried by packets going upstream from user-side devices (such as a home gateway), U-VLAN for short.
  • C-VLAN: VLAN added based on the ONT/ONU port. For details, see the description of the Double-tagged VLAN S+C.
  • Double-tagged VLAN S+C: C indicates the inner VLAN (C-VLAN) and S indicates the outer VLAN (S-VLAN).
  • Double-tagged VLAN S+C': C' indicates the translated inner VLAN (C'-VLAN) and S indicates the outer VLAN (S-VLAN).
  • Single-tagged S-VLAN: Single-tagged VLAN marked or translated by the OLT. It is generally used in a single-tagged VLAN translation scenario.
  • C<->S+C': Bidirectional VLAN translation: translates the C-VLAN and then adds an S-VLAN.
  • C<->S+C: Bidirectional VLAN translation: maintains the C-VLAN and adds an S-VLAN.
NOTE:
  • The voice service is a closed service operated by carriers. The single-tagged S-VLAN is the mainstream application and is recommended.
  • When the planned VLAN is single-tagged VLAN, the S-VLANs can be allocated based on the OLT device, PON board or PON port. The S-VLANs identify services and physical locations. It is recommended that you set different voice VLANs for the OLTs connected to one voice SR to avoid an excessively large broadcast domain of the SR and convergence switch.
  • When the planned VLAN is S-VLAN+C-VLAN (that is, double-tagged VLAN), the outer S-VLANs can be allocated based on the OLT device, PON board or PON port. The S-+VLANs identify services and physical locations. It is recommended to allocate S-VLANs based on PON board or PON port. The inner C-VLAN is used to identify services (a fixed value) or users.

Voice Data Plan Based on H.248 or SIP

Item

Description

MG interface/SIP interface data

NOTE:
must be consistent with the data on the MGC/IMS core network devices.

Media and signaling parameters

Media and signaling upstream VLANs

Upstream VLANs of the voice service

Media and signaling upstream port

Upstream ports of the voice service

Media IP addresses and signaling IP addresses

Supports separating media from signaling.

Default gateway IP address.

The next hop IP address from an ONU/HGW to an MGC/IMS.

MG interface/SIP interface ID

N/A

Signaling port ID

Choose the transmission mode according to the requirement of the MGC/IMS side.

IP address of active MGC (H.248)/IP address of active IMS device (SIP)

If the dual homing is not configured, only one MGC parameter needs to be configured. If the dual homing is configured, the IP address and port ID of the standby MGC need to be configured.

Port ID of active MGC (H248)/port ID of active IMS device (SIP)

Coding

Choose the coding method according to the requirement on the MGC/IMS side. Generally, the text coding method is adopted.

Transmission mode

Choose the transmission mode according to the requirement on the MGC/IMS side. Generally, the UDP transmission mode is adopted.

Home domain (SIP)

N/A

Profile index

N/A

The version of H248 protocol that MG starts to negotiate

V1, V2 or V3 (by default). The interface may fail to be registered because some softswitches do not support V3.

Voice user configuration data

Phone number

For H248 protocol: The phone numbers allocated by the MGC need to be determined, and the paging numbers for users' emergency standalone need to be planned if the emergency standalone function is provided.

For SIP protocol: The phone number that the IMS core network device allocates to the user must be configured.

Terminal ID (H248)

If the TID template with which the POTS user is bound does not support terminal layering, this parameter needs to be configured.

User priority
According to the service requirements, user priorities must be specified. The user priorities include the following:
  • cat1: government1 (category 1 government users)
  • cat2: government2 (category 2 government users)
  • cat3: common (common users)

User type
According to the service requirements, user type needs to be specified. The user type includes the following:
  • DEL: direct exchange lines (default)
  • ECPBX: earth calling PBX
  • LCPBX: loop calling PBX
  • PayPhone: pay phone

Common parameter

system parameter

The system parameters including the overseas version flag and message waiting indication (MWI) mode need to be configured according to the local standard to ensure that the response of the user terminal complies with the local standard.

Overseas parameters

The attributes such as the upper and lower thresholds of the flash-hooking duration need to be configured according to the local standards to ensure that the response of the user terminal complies with the local standards.

POTS port attributes

If the POTS port needs to support the polarity reversal accounting, the POTS port needs to be configured to support the polarity reversal pulse. Other attributes need not be modified if there is no special requirement.

Ringing current attributes

When the attributes of ring current are changed, ring volume is changed accordingly. Generally, no adjustment is required for the ringing tone volume. You need to modify the parameters of the ringing current attributes according to the local standard only when the default ringing current attributes do not comply with the local standard.

Parent Topic: Principle of FTTH Data Plan


Principle of IPTV Service Data Plan

The IPTV service data plan mainly include the plan of VLAN and VLAN translation policy in different network scenario, and the plan of IPTV service.

IPTV services include multicast service and video on demand (VoD) service. These two services are relevant but independent in VLAN planning.

Application Scenario | Service Type | VLAN Plan | VLAN Translation Policy
Bridging+Voice ONT | Multicast service | Single-tagged VLAN | ONTs replicate multicast packets based on user ports and multicast VLANs (M-VLANs) are removed downstream. The OLT replicates multicast packets based on PON ports with M-VLAN unchanged.
 | VoD | Single-tagged VLAN | ONTs add S-VLAN tags to iTV service packets. The OLT transparently transmits packets with S-VLANs.
 |  | Double-tagged VLAN | All ONTs add the same C-VLAN tag to packets. The OLT implements VLAN translation: C->S+C'.
Bridging ONT + HGW | Multicast service | Single-tagged VLAN | ONTs transparently transmit upstream packets with M-VLANs sent from HGW. Multicast packets are replicated downstream with M-VLAN unchanged. The OLT replicates multicast packets based on PON ports with M-VLAN unchanged.
 |  | Single-tagged VLAN | ONTs translate the upstream VLANs sent from HGW to M-VLANs. The OLT replicates multicast packets based on PON ports with M-VLAN unchanged.
 | VoD | Single-tagged VLAN | ONTs transparently transmit the upstream U-VLANs sent from HGW. The OLT implements VLAN translation: U->S.
 |  | Double-tagged VLAN | ONTs transparently transmit the upstream U-VLANs sent from HGW. The OLT implements VLAN translation: U->S+C.
Gateway ONT | Multicast service | Single-tagged VLAN | ONTs replicate packets based on user ports and M-VLANs are removed in downstream direction. The OLT replicates multicast packets based on PON ports with M-VLAN unchanged.
 | VoD | Single-tagged VLAN | ONTs add C-VLAN tags to packets. Untagged VLANs are translated to C-VLANs. The OLT implements VLAN translation: C -> S.
Note:
  • User VLAN: VLAN carried by packets going upstream from user-side devices (such as a home gateway), U-VLAN for short.
  • C-VLAN: VLAN added based on the ONT/ONU port. For details, see the description of the Double-tagged VLAN S+C.
  • Double-tagged VLAN S+C: C indicates the inner VLAN (C-VLAN) and S indicates the outer VLAN (S-VLAN).
  • Double-tagged VLAN S+C': C' indicates the translated inner VLAN (C'-VLAN) and S indicates the outer VLAN (S-VLAN).
  • Single-tagged S-VLAN: Single-tagged VLAN marked or translated by the OLT. It is generally used in a single-tagged VLAN translation scenario.
  • C<->S+C': Bidirectional VLAN translation: translates the C-VLAN and then adds an S-VLAN.
  • C<->S+C: Bidirectional VLAN translation: maintains the C-VLAN and adds an S-VLAN.
NOTE:
  • IPTV service is a closed service self-operated by carriers, and single-tagged S-VLAN is recommended.
  • The same S-VLAN or different S-VLANs can be used as the M-VLAN and VoD VLAN. It is recommended that you use different S-VLANs as M-VLAN and VoD VLAN so that the upper-level device easily differentiates between the BTV service and VoD service.
  • S-VLANs of VoD service can identify services and physical locations based on an entire network or an OLT. It is recommended that you set different VoIP VLANs for the OLTs connected to one VoIP SR to avoid an excessively large broadcast domain of the VoIP SR and convergence switch.
Parent Topic: Principle of FTTH Data Plan


Principle of Security Data Plan

The security plan involves system security plan, user security plan, and service security plan. Security policy ensures service security from different aspects.

NOTE:
The device provides complete security measures, but not all security measures need to be deployed. Only the security measures that meet the following requirements need to be deployed:
  • The security measures can be used on the live network.
  • The security measures are easy to deploy.
  • The security measures are effective.

System Security

Security Vulnerability | Solution | Description and Usage Suggestion
DoS attack | Enable the anti-DoS-attack function for OLT. | After the anti-DoS-attack function is enabled, control packets are monitored and those exceeding the number threshold are discarded. Use this solution for new site deployment.
IP attack | Enable the anti-IP-attack function for OLT. | After the anti-IP-attack function is enabled, a device discards the IP packets received from the user side whose destination IP address is the IP address of the device, and therefore the system is protected. Use this solution for new site deployment.

User Security

Security Vulnerability | Solution | Description and Usage Suggestion
MAC spoofing | Enable the anti-MAC-duplicate function for OLT. | After anti-MAC-duplicate is enabled, the system records the first MAC address learned from the port and binds the MAC address to the port and VLAN. If receiving packets sent from the host that has the same MAC address with the port, the system discards the packets directly. In this case, it can prevent users from forging MAC addresses to perform malicious attacks. Use this solution for new site deployment.
MAC attack | Enable the anti-MAC spoofing function for OLT. | After anti-MAC spoofing is enabled, the system can prevent users from forging MAC addresses to perform malicious attacks. Use this solution for new site deployment.
IP spoofing | Enable the anti-IP spoofing function for OLT. | After anti-IP spoofing is enabled, the system can prevent users from forging IP addresses to perform malicious attacks. Use this solution for new site deployment.

Service Security

Security Vulnerability

Solution

Description and Usage Suggestion

Unauthorized broadband access of small enterprises (IPoE)

DHCP option 82 is enabled on OLT, and the BRAS implements user authentication based on the RAIO information.
In the DHCP option 82 mode, user's physical location is added to the option 82 field carried in the DHCP request packet initiated by a user. The physical location, used for user authentication on the upper-layer authentication server, can help implement the following functions:
  • The DHCP relay forwards DHCP response packets to devices with specified CID and RID.
  • Prevents DHCP address exhaustion.
  • Achieves static allocation of DHCP addresses.
  • Implements anti-IP spoofing.
  • Implements anti-user ID spoofing.
  • Implements anti-MAC spoofing.

Use this solution for the DHCP Internet access service.

Broadband access of residential users (PPPoE), user account theft/borrowing

PPPoE+ (PITP) is enabled on OLT, and the BRAS implements user authentication based on binding of the RAIO information to the user account.
The BRAS responds to request packets of users with specified CID and RID. In this way, the following functions are implemented:
  • Prevents IP address exhaustion.
  • Implements anti-IP spoofing.
  • Implements anti-user ID spoofing.
  • Implements anti-MAC spoofing.

Use this solution for the PPPoE Internet access service.
Parent Topic: Principle of FTTH Data Plan
Huawei Proprietary and Confidential Copyright © Huawei Technologies Co., Ltd.
Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.
< Previous topic


Configuring the Bridging-Type ONT (HG8010H/HG8040H/HG8050P/HG8012H)

This topic describes the configuration of bridging-type ONTs and their web pages. Bridging-type ONTs only support Layer 2 features.

    Configuring the Service by Using the NMS
    This topic describes how to configure Internet access service, VoIP service and IPTV service by using the NMS.
    Configuration by Using OLT Commands
    This topic describes how to configure the Internet access service, VoIP service and IPTV service by using OLT commands.
    Configuring FTTH IPv6 Services in Bridging-type ONT Scenario (Dual Stack/DS-Lite)
    This topic describes how to configure FTTH IPv6 services when the ONT is a bridging-type ONT and the dual stack or DS-Lite solution is used.


Configuring the Service by Using the NMS

This topic describes how to configure Internet access service, VoIP service and IPTV service by using the NMS.

    Configuring FTTH Services (GPON Access)
    This topic describes how to configure the Internet service, voice service, and multicast service in GPON access mode in the FTTH network scenario using the U2000.
Parent Topic: Configuring the Bridging-Type ONT (HG8010H/HG8040H/HG8050P/HG8012H)
Huawei Proprietary and Confidential Copyright © Huawei Technologies Co., Ltd.
Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.
Next topic >


Configuring FTTH Services (GPON Access)

This topic describes how to configure the Internet service, voice service, and multicast service in GPON access mode in the FTTH network scenario using the U2000.

    Configuring the GPON FTTH Layer 2 Internet Access Service on the NMS
    Services can be configured for an ONT only after the ONT is successfully added to an OLT.
    Configuring the GPON FTTH Layer 2 Multicast Service on the NMS
    This topic describes how to configure the multicast service when an ONT is connected to an OLT through a GPON port.
Parent Topic: Configuring the Service by Using the NMS


Configuring the GPON FTTH Layer 2 Internet Access Service on the NMS

Services can be configured for an ONT only after the ONT is successfully added to an OLT.

Networking

  • The PC gains access to the Internet in PPPoE dialup mode.
  • The ONT is connected to the GPBC card of the OLT through an optical fiber.
  • The broadband remote access server (BRAS) provides broadband user access and functions of authentication and accounting.
Figure 1 Configuring the GPON FTTH Internet service

Data Plan

Table 1 Data plan

Item

Data

DBA profile

Name: ftth_dba

DBA Type: Assured Bandwidth/Maximum Bandwidth

Assured bandwidth: 8 Mbit/s

Maximum bandwidth: 20 Mbit/s

ONT line profile

Profile name: ftth

T-CONT ID: 4

GEM port ID for Internet access services: 14

ONT service profile

Profile name: ftth

ONT port capability set:

  • Number of POTS Ports: Adaptive
  • Number of ETH Ports: Adaptive
  • Number of CATV Ports: Adaptive

Network topology data

Upstream port: 0/19/0

PON port: 0/1/0

ONT ID: 1

ID of the port on the ONT that is connected to the PC: 1

VLAN plan

Double-tagged VLAN

  • S-VLAN ID: 100
  • S-VLAN type: Smart
  • S-VLAN attribute: Stacking
  • C-VLAN ID: 1001
  • C'VLAN ID: 1010
NOTE:
VLAN translation policy:

  • ONT: ONTs configure the VLAN and add the same C-VLAN tag to packets. All ONTs are in the same C-VLAN.

  • OLT: The OLT performs VLAN translation: C<->S+C'. The C'-VLAN of every ONT differs from each other.

Procedure

  • Implement pre-configurations.

    NOTE:
    After all profiles are configured, perform the following steps to issue them to the device:
    • In the information list, right-click the record and choose Download to NE from the shortcut menu.
    • In the dialog box that is displayed, select the required NE(s), and click OK.

    1. Configure a DBA profile.

    2. Configure a line profile.

      In a line profile, a GEM port can be bound to up to eight service streams. In a GEM port, different GEM connections need to be set up for different service streams.

      In this example, the mapping between GEM ports and ONT-side services is implemented through VLANs, and the service streams of each service are mapped to GEM port 14. In addition, different GEM connections are set up for the management VLAN and the VLANs for the Internet, voice, and multicast services.

    3. Configure a service profile.

      Set the port capability set to adaptive. Then, the system adapts the port capability set of an online ONT to its actual capability. Then, in the ONT service profile, configure a VLAN translation policy to translate C-VLAN 1001 to VLAN 100.

    4. Configure an MEF IP traffic profile.

      The profile name is ftth_hsi, CIR is 4 Mbit/s, and the priority is 0. Traffic is scheduled based on the priority specified in the profile.

    5. Configure a service VLAN on the OLT side.

      The prerequisite for performing operations in the navigation tree is to navigate to the NE Explorer of the OLT. To navigate to the NE Explorer of the OLT, do as follows: In the Main Topology, double-click the required OLT in the Physical Root navigation tree; or right-click the required OLT and choose NE Explorer from the shortcut menu.

      A service VLAN is the VLAN used for the Internet service.

  • Provision services.

    The prerequisite for performing operations in the navigation tree is to navigate to the NE Explorer of the OLT. To navigate to the NE Explorer of the OLT, do as follows: In the Main Topology, double-click the required OLT in the Physical Root navigation tree; or right-click the required OLT and choose NE Explorer from the shortcut menu.

    1. Add an ONT.

      The ONT connects to the GPON port 0/1/0 is ONT 1. The serial number of the ONT is 32303131D659FD40, password is 0100000001, discovery mode for password authentication is Always On, management mode is OMCI, bound ONT line profile name is ftth, and the ONT service profile name is ftth.

      NOTE:

      HG8010H is used as an example. For other ONTs, set Terminal Type based on practical conditions.

      The ONT software version is the same (V3R017C10) for the SIP protocol and H.248 protocol.

    2. Configure an ETH port of the GPON ONU.

    3. Add a service virtual port on the OLT side.

Result

Check whether the user successfully gains access to the Internet through dialup on the PC.
  1. The LAN1 port of the ONT is connected to the Ethernet port of the PC properly.
  2. Dial up on the PC using the PPPoE dialup software.
  3. The user gains access to the Internet on the PC after the dialup is successful.
Parent Topic: Configuring FTTH Services (GPON Access)
Huawei Proprietary and Confidential Copyright © Huawei Technologies Co., Ltd.
Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.
Next topic >


Configuring the GPON FTTH Layer 2 Multicast Service on the NMS

This topic describes how to configure the multicast service when an ONT is connected to an OLT through a GPON port.

Networking

  • The ONT is connected to the OLT in Layer 2 mode.
  • The OLT uses IGMP proxy, which is a Layer 2 multicast protocol.
  • The IGMP version of the multicast VLAN is IGMPv2.
  • The multicast programs are obtained in the dynamic mode.
Figure 1 Configuring the GPON FTTH multicast service

Data Plan

Table 1 Data plan

Item

Data

DBA profile

Name: ftth_dba

DBA Type: Assured Bandwidth/Maximum Bandwidth

Assured bandwidth: 8 Mbit/s

Maximum bandwidth: 20 Mbit/s

ONT line profile

Profile name: ftth

T-CONT ID: 4

GEM port ID for video services: 13

ONT service profile

Profile name: ftth

ONT port capability set:

  • Number of POTS Ports: Adaptive
  • Number of ETH Ports: Adaptive
  • Number of CATV Ports: Adaptive

Network topology data

Upstream port: 0/19/0

PON port: 0/1/0

ONT ID: 1

ID of the port on the ONT that is connected to the PC: 2

Multicast service data

Multicast protocol: IGMP proxy

Multicast version: IGMPv2

Multicast program: dynamic obtaining mode

VLAN Plan
  • S-VLAN ID: 1000
  • MVLAN ID: 1000
  • VLAN type: Smart
  • VLAN attribute: Common
NOTE:
VLAN translation policy:

  • ONT: transparently transmits the MVLAN of the HGW. Multicast packets are duplicated downstream with MVLAN unchanged.

  • OLT: duplicates multicast packets based on PON ports with MVLAN unchanged.

Procedure

  • Implement pre-configurations.

    NOTE:
    After all profiles are configured, perform the following steps to issue them to the device:
    • In the information list, right-click the record and choose Download to NE from the shortcut menu.
    • In the dialog box that is displayed, select the required NE(s), and click OK.

    1. Configure a DBA profile.

    2. Configure a line profile.

      In a line profile, a GEM port can be bound to up to eight service streams. In a GEM port, different GEM connections need to be set up for different service streams.

      In this example, the mapping between GEM ports and ONT-side services is implemented through VLANs, and the service streams of each service are mapped to GEM port 13. In addition, different GEM connections are set up for the management VLAN and the VLANs for the Internet, voice, and multicast services.

    3. Configure a service profile.

      Configure a VLAN translation policy for the ONT ETH port. Assume that the ONT connects to the HGW through ETH port 2. Configure a VLAN translation policy to make the ONT transparently transmit the MVLAN of the HGW in the upstream direction, and replicate multicast packets with the MVLAN unchanged in the downstream direction.

    4. Configure an MEF IP traffic profile.

      The profile name is ftth_iptv, CIR is off, priority is 4, and priority-based scheduling policy is Local-Setting. Traffic is scheduled based on the priority specified in the profile.

    5. Configure an S-VLAN on the OLT side.

      The prerequisite for performing operations in the navigation tree is to navigate to the NE Explorer of the OLT. To navigate to the NE Explorer of the OLT, do as follows: In the Main Topology, double-click the required OLT in the Physical Root navigation tree; or right-click the required OLT and choose NE Explorer from the shortcut menu.

      The S-VLAN is used for the multicast service.

  • Provision services.

    The prerequisite for performing operations in the navigation tree is to navigate to the NE Explorer of the OLT. To navigate to the NE Explorer of the OLT, do as follows: In the Main Topology, double-click the required OLT in the Physical Root navigation tree; or right-click the required OLT and choose NE Explorer from the shortcut menu.

    1. Add an ONT.

      The ONT connects to the GPON port 0/1/0 is ONT 1. The serial number of the ONT is 32303131D659FD40, password is 0100000001, discovery mode for password authentication is Always On, management mode is OMCI, bound ONT line profile name is ftth, and the ONT service profile name is ftth.

      NOTE:

      HG8010H is used as an example. For other ONTs, set Terminal Type based on practical conditions.

      The ONT software version is the same (V3R017C10) for the SIP protocol and H.248 protocol.

    2. Configure Ethernet port attributes and service channels of a GPON ONU.

    3. Add a service virtual port on the OLT side.

    4. Add a multicast VLAN on the OLT side.

      NOTE:
      Program match mode can be set when IGMP Work Mode is tv_off. The values of Program match mode are as follows:
      • Enable: Multicast programs are configured statically. Dynamic program generation is not supported.
      • Disable: Multicast programs are dynamically generated. Static program configuration is not supported.

      After Configuration, IGMP Work Mode should be set to Proxy again, otherwise IGMP work abnormally.

    5. Add a virtual multicast upstream port on the OLT side.

    6. Configure a multicast user on the OLT side.

Result

The user can watch programs on TV.

Parent Topic: Configuring FTTH Services (GPON Access)
Huawei Proprietary and Confidential Copyright © Huawei Technologies Co., Ltd.
Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.
< Previous topic


Configuration by Using OLT Commands

This topic describes how to configure the Internet access service, VoIP service and IPTV service by using OLT commands.

    Bridging ONT + HGW Network Scenario (GPON and 10G GPON Access)
    This topic describes how to configure Internet access service, voice service, BTV service and VoD service when bridging ONTs + HGWs are used to build an FTTH network.
Parent Topic: Configuring the Bridging-Type ONT (HG8010H/HG8040H/HG8050P/HG8012H)


Bridging ONT + HGW Network Scenario (GPON and 10G GPON Access)

This topic describes how to configure Internet access service, voice service, BTV service and VoD service when bridging ONTs + HGWs are used to build an FTTH network.

The FTTH GPON and 10G GPON access have the same configuration procedure. ONT web pages for configuring them have differences; however, they have the same configuration parameters. The following uses GPON ONT configuration as an example. For differences on web pages, see the related ONT manuals.

    Service Requirements and Application Scenario
    Configuration Roadmap (Flash)
    Configuration Process
    Adding an ONT to an OLT
    Services can be configured for an ONT only after the ONT is successfully added to an OLT.
    Configuring the Internet Access Service
    The OLT is connected to the remote ONT through a GPON port to provide users with high-speed Internet access services.
    Configuring the Voice Service
    The OLT is connected to the remote ONT through a GPON port to provide users with the IP-based high-quality and low-cost VoIP service.
    Configuring the BTV Service
    The OLT is connected to the remote bridging ONT through a GPON port to provide users with the multicast service.
    Configuring the VoD Service
    The OLT is connected to the remote bridging ONT through a GPON port to provide users with the VoD service.
    Configuring Link Aggregation, Congestion Control, and Security Policy
    The global configuration of link aggregation and queue scheduling based on priorities ensures service reliability. The global configuration of security policies ensures service security.
    Verifying Services
    In the FTTH scenario, ONTs are installed in users' houses which are far away from the central equipment room. ONTs provide remote service verification methods including PPPoE dialup emulation, call emulation, and multicast emulation to facilitate configuration and commissioning engineers to verify services remotely after service configuration.
Parent Topic: Configuration by Using OLT Commands


Service Requirements and Application Scenario

Service Requirements

Optical fibers are connected to user homes and triple play services are required. The following provides detailed service requirements:
  • Internet access of multiple PCs in a home is supported.
  • Access of multiple telephones in a home is supported.
  • IPTV programs can be previewed and watched using STBs.
  • Service extension is supported and different services do not affect each other.
  • Proper service security is ensured.
    • Internet access services are protected against unauthorized access, user account theft or borrowing, MAC/IP spoofing, and malicious attacks.
    • Voice and IPTV services are protected against MAC/IP spoofing, malicious attack, and traffic flooding attacks.
  • Service faults are easy to locate and services are easy to maintain.

Application Scenario

As shown in Figure 1, the HGW integrating an IAD provides Internet, voice over Internet Protocol (VoIP), and Internet Protocol television (IPTV) services to users.

Services are mainly implemented on the HGW, and the bridging ONT works with the OLT to provide Layer 2 channels.

Figure 1 Bridging ONT + HGW
Parent Topic: Bridging ONT + HGW Network Scenario (GPON and 10G GPON Access)
Huawei Proprietary and Confidential Copyright © Huawei Technologies Co., Ltd.
Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.
Next topic >


Configuration Roadmap (Flash)

The configuration roadmap flash for Bridging ONT + HGW Network Scenario is as follows:

Parent Topic: Bridging ONT + HGW Network Scenario (GPON and 10G GPON Access)


Configuration Process

Figure 1 shows the configuration roadmap in fiber to the home (FTTH) networking using a bridging optical network terminal (ONT)+home gateway (HGW).

Figure 1 Configuration roadmap in FTTH networking using a bridging ONT+HGW

The following table describes the configuration steps.

Item

Step

Description

Optical line terminal (OLT)

Adding an ONT to an OLT

Services can be configured for an ONT only after the ONT is successfully added to an OLT.

OLT

HGW

Configuring the Internet Access Service
  • An ONT provides only Layer 2 service channels, which do not require configuration. An HGW is equipped with an integrated access device (IAD) provides the Internet access, VoIP, and IPTV services for users.
  • IPTV services include the BTV and VoD services that are different in configuration procedures and need to be configured separately.

Configuring the Voice Service

Configure the IPTV service.

Configuring the BTV Service

Configuring the VoD Service

OLT

Configuring Link Aggregation, Congestion Control, and Security Policies

The global configuration of link aggregation and queue scheduling based on priorities ensures service reliability. The global configuration of security policies ensures service security.

OLT

Verifying Services

The OLT provides remote verification methods including ONT PPPoE/DHCP dialup emulation and call emulation for configuration and commissioning engineers to verify services remotely after service configuration, avoiding a second on-site operation.

Parent Topic: Bridging ONT + HGW Network Scenario (GPON and 10G GPON Access)


GPON Access: Adding an ONT to an OLT.

< Home

Adding an ONT to an OLT

Services can be configured for an ONT only after the ONT is successfully added to an OLT.

Data Plan

Item

Data

DBA profile
Profile name: ftth_dba_mngt
  • Profile type: Type1
  • Fixed bandwidth: 1 Mbit/s
Profile name: ftth_dba_hsi
  • Profile type: Type4
  • Maximum bandwidth: 32 Mbit/s
Profile name: ftth_dba_voip
  • Profile type: Type2
  • Assured bandwidth: 1 Mbit/s
Profile name: ftth_dba_iptv
  • Profile type: Type2
  • Assured bandwidth: 1 Mbit/s

ONT line profile

Profile name: ftth

T-CONT ID for management services: 4

T-CONT ID for voice services: 5

T-CONT ID for video services: 6

T-CONT ID for Internet access services: 7

GEM port ID for management services: 11

GEM port ID for voice services: 12

GEM port ID for video services: 13

GEM port ID for Internet access services: 14

ONT service profile

Profile name: ftth

ONT port capability set: adaptive

Network topology data

PON port: 0/1/0

ONT IDs: 1 and 2

Procedure

  1. Configure GPON ONT profiles.

    GPON ONT profiles include the DBA profile, line profile, service profile, and alarm profile.
    • DBA profile: A DBA profile describes the GPON traffic parameters. A T-CONT is bound to a DBA profile for dynamic bandwidth allocation, improving upstream bandwidth utilization.
    • Line profile: A line profile describes the binding between the T-CONT and the DBA profile, the QoS mode of the traffic stream, and the mapping between the GEM port and the ONT-side service.
    • Service profile: A service profile provides the service configuration channel for the ONT that is managed by using optical network terminal management and control interface (OMCI).
    • Alarm profile: An alarm profile contains a series of alarm thresholds to measure and monitor the performance of activated ONT lines. When a statistical value reaches the threshold, the host is notified and an alarm is reported to the log host and the NMS.

    1. Configure a DBA profile.

      Run the display dba-profile command to query the existing DBA profiles in the system. If the existing DBA profiles in the system cannot meet the requirements, run the dba-profile add command to add a DBA profile.

      huawei(config)#dba-profile add profile-name ftth_dba_mngt type1 fix 1024
huawei(config)#dba-profile add profile-name ftth_dba_voip type2 assure 1024
huawei(config)#dba-profile add profile-name ftth_dba_iptv type2 assure 1024
huawei(config)#dba-profile add profile-name ftth_dba_hsi type4 max 32768

      NOTE:
      Select a DBA profile of the proper bandwidth type and configure proper bandwidth according to the service types and total user count of the ONT. Note that the sum of the fixed bandwidth and the assured bandwidth must not be greater than the total bandwidth of the PON port.

    2. Configure an ONT line profile.

      Create a GPON ONT line profile, named ftth, and bind it to the DBA profile.

      huawei(config)#ont-lineprofile gpon profile-name ftth
huawei(config-gpon-lineprofile-1)#tcont 4 dba-profile-name ftth_dba_mngt
huawei(config-gpon-lineprofile-1)#tcont 5 dba-profile-name ftth_dba_voip
huawei(config-gpon-lineprofile-1)#tcont 6 dba-profile-name ftth_dba_iptv
huawei(config-gpon-lineprofile-1)#tcont 7 dba-profile-name ftth_dba_hsi
      Create different GEM ports according to different service types, in which
      • GEM port 11 is used to carry management services.
      • GEM port 12 is used to carry voice services.
      • GEM port 13 is used to carry video services.
      • GEM port 14 is used to carry Internet access services.
      huawei(config-gpon-lineprofile-1)#gem add 11 eth tcont 4
huawei(config-gpon-lineprofile-1)#gem add 12 eth tcont 5
huawei(config-gpon-lineprofile-1)#gem add 13 eth tcont 6
huawei(config-gpon-lineprofile-1)#gem add 14 eth tcont 7
      NOTE:
      1. To change the default QoS mode, run the qos-mode command to set the QoS mode to gem-car or flow-car, and run the gem add command to set the index of the traffic profile bound to the GEM port.
      2. When the QoS mode is priority-queue (PQ), the default queue priority is 0; when the QoS mode is flow-car or gem-car, traffic profile 6 is bound to the GEM port by default (no rate limitation).

      After the configurations are complete, run the commit command to apply the parameters settings.

      huawei(config-gpon-lineprofile-1)#commit
huawei(config-gpon-lineprofile-1)#quit
    3. Configure an ONT service profile.

      Create a GPON ONT service profile, named ftth. Configure the capability set of the ETH port and POTS port to adaptive. Then the system automatically adapts to the ONT according to the actual capability of the online ONT.

      huawei(config)#ont-srvprofile gpon profile-name ftth
huawei(config-gpon-srvprofile-1)#ont-port eth adaptive pots adaptive

      After the configurations are complete, run the commit command to apply the parameters setting.

      huawei(config-gpon-srvprofile-1)#commit
huawei(config-gpon-srvprofile-1)#quit
    4. (Optional) Add an alarm profile.

      • The default GPON alarm profile 1 is used. The alarm thresholds for the default alarm profile are 0, which indicates that no alarm is generated.
      • In this example, the default alarm profile is used, and therefore the configuration of the alarm profile is not required.
      • Run the gpon alarm-profile add command to configure a GPON alarm profile, which is used for monitoring the performance of an activated ONT line.

  2. Add an ONT.

    Connect two ONTs to GPON port 0/1/0. Set the ONT IDs to 1 and 2, SNs to 3230313126595540 and 6877687714852901, passwords to 0100000001 and 0100000002, discovery mode for password authentication to once-on, and management mode to OMCI. Bind the two ONTs to ONT line profile ftth and ONT service profile ftth.

    There are two methods of adding an ONT: add an ONT offline and confirm an automatically discovered ONT.

    • Add ONTs offline.

      If the password of an ONT is known, run the ont add command to add an ONT offline.

      huawei(config)#interface gpon 0/1
huawei(config-if-gpon-0/1)#ont add 0 1 password-auth 0100000001 once-on no-aging omci ont-lineprofile-name
 ftth ont-srvprofile-name ftth
huawei(config-if-gpon-0/1)#ont add 0 2 password-auth 0100000002 once-on no-aging omci ont-lineprofile-name
 ftth ont-srvprofile-name ftth

    • Confirm automatically discovered ONTs.

      If the password or SN of an ONT is unknown, run the port portid ont-auto-find command in GPON mode to enable the ONT auto-discovery function of the GPON port. Then, run the ont confirm command to confirm the ONT.

      huawei(config)#interface gpon 0/1
huawei(config-if-gpon-0/1)#port 0 ont-auto-find enable
huawei(config-if-gpon-0/1)#display ont autofind 0
  //After this command is executed, the information about all ONTs connected to the GPON port through optical splitters is displayed.

huawei(config-if-gpon-0/1)#ont confirm 0 ontid 1 sn-auth 3230313126595540 omci ont-lineprofile-name
 ftth ont-srvprofile-name ftth
huawei(config-if-gpon-0/1)#ont confirm 0 ontid 2 sn-auth 6877687714852901 omci ont-lineprofile-name
 ftth ont-srvprofile-name ftth
      NOTE:
      If multiple ONTs of the same type bound to the same line profile or service profile are connected to the same port, you can bulk add ONTs by bulk confirming automatically discovered ONTs to make configuration easier and more efficient. To do so, the preceding command can be modified as follows:
      huawei(config-if-gpon-0/1)#ont confirm 0 all sn-auth omci ont-lineprofile-name ftth
ont-srvprofile-name ftth

    • (Optional) Bind the alarm profile to the ONT.

      The default profile 1 is used in this example.

      huawei(config-if-gpon-0/1)#ont alarm-profile 0 1 profile-id 1
huawei(config-if-gpon-0/1)#ont alarm-profile 0 2 profile-id 1

  3. Check ONT status.

    After an ONT is added, run the display ont info command to query the current status of the ONT. Ensure that Config flag of the ONT is active, Run State is online, Config state is normal, and Match state is match.

    huawei(config-if-gpon-0/1)#display ont info 0 1
  ---------------------------------------------------------------------
  F/S/P                : 0/1/0
  ONT-ID               : 1
  Control flag         : active    //Indicates that the ONT is activated.
  Run state            : online    //Indicates that the ONT goes online successfully.
  Config state         : normal    //Indicates that the configuration state of the ONT is normal.
  Match state          : match     //Indicates that the capability profile bound to the ONT is consistent with the actual capability of the ONT.
...//The rest of the response information is omitted.
    When Config state is failed, Run state is offline, or Match state is mismatch:
    • If Control flag is deactive, run the ont active command in GPON mode to activate the ONU.
    • If Run state is offline, a physical line may be broken or the optical module may be damaged. Check the line and the optical module.
    • If Config state is failed, the configured ONU capability exceeds the actual ONU capability. In this case, run the display ont failed-configuration command in the diagnose mode to check the failed configuration item and the failure cause. Then, rectify the fault accordingly.
    • If the ONU does not match, that is, Match state is mismatch, the port types and number of ports undermatch the actual port types and number of ports supported by the ONU. In this case, run the display ont capability command to query the actual capability of the ONU, and then select one of the following modes to modify the ONU configuration:
      • Create a proper ONU profile according to the actual capability of the ONU, and then run the ont modify command to modify the configuration data of the ONU.
      • Modify the ONU profile according to the actual capability of the ONU and save the modification. Then, the ONU automatically recovers the configuration successfully.
Parent Topic: Bridging ONT + HGW Network Scenario (GPON and 10G GPON Access)


Configuring the Internet Access Service

The OLT is connected to the remote ONT through a GPON port to provide users with high-speed Internet access services.

Prerequisites

  • The OLT is connected to the BRAS.
  • Related configurations are performed on the BRAS according to the authentication and accounting requirements for dialup users. For details about the configuration, see the configuration guide.
  • The ONT has been added to the OLT. For details, see Adding an ONT to an OLT.
  • The VLAN of the LAN switch port connected to the OLT is consistent with the upstream VLAN of the OLT.
  • Residential users generally access the Internet in Point-to-Point Protocol over Ethernet (PPPoE) dial-up mode. PPPoE dial-up can be performed on personal computers (PCs) or HGWs.
  • The configuration processes on HGWs of different models or in different appearances are similar. This topic describes how to configure the Internet access service on an HG239 that is connected to an ONT upstream through a LAN.

Data Plan

Item

Data

ONT line profile

Profile name: ftth

GEM port ID for Internet access service: 14

Network topology data

Upstream port: 0/19/0

PON port: 0/1/0

ONT IDs: 1 and 2

ID of the port on the HGW that is connected to the PC: 1

VLAN Plan
Double-tagged VLAN:
  • S-VLAN ID: 100
  • S-VLAN type: smart
  • S-VLAN attribute: stacking
  • C-VLAN ID: 1001-1002
  • U-VLAN ID: 45
VLAN translation policy:
  • ONT: The upstream packets sent from the HGW carry user-VLANs and the ONT transparently transmits them.
  • OLT: The OLT translates the U-VLAN to S-VLAN+C-VLAN.

Procedure

  • Configure the OLT.
    1. Configure a traffic profile.

      Run the display traffic table ip command to query the existing traffic profiles in the system. If the traffic profiles existing in the system do not meet the requirements, you need to run the traffic table ip command to add a traffic profile.

      Set the profile ID to ftth_hsi, the CIR to 4 Mbit/s, and the priority to 0. In addition, configure the scheduling mode so that packets are scheduled according to their priorities.

      huawei(config)#traffic table ip name ftth_hsi cir 4096 priority 0 priority-policy local-setting

    2. Configure the mapping between a GEM port and a VLAN.

      The service flow of user-side VLAN 45 is mapped to GEM port 14 in the ONT line profile.
      NOTE:
      Here, the user-side VLAN is the VLAN carried by packets sent from HGW to ONT, namely, U-VLAN.
      huawei(config)#ont-lineprofile gpon profile-name ftth
huawei(config-gpon-lineprofile-1)#gem mapping 14 0 vlan 45
huawei(config-gpon-lineprofile-1)#commit
huawei(config-gpon-lineprofile-1)#quit

    3. Configure the VLAN of the Ethernet port on the ONT.

      Add Ethernet port 1 to VLAN 45 in the ONT service profile.

      huawei(config)#ont-srvprofile gpon profile-name ftth
huawei(config-gpon-srvprofile-1)#port vlan eth 1 45
huawei(config-gpon-srvprofile-1)#commit

    4. Create an Internet access service VLAN and add an upstream port to it.

      Add upstream port 0/19/0 to VLAN 100.

      huawei(config)#vlan 100 smart
huawei(config)#vlan attrib 100 stacking
huawei(config)#port vlan 100 0/19 0

    5. Create Internet access service flows.

      Set S-VLAN ID to 100 and GEM port ID to 14. Use traffic profile ftth_hsi.

      huawei(config)#service-port vlan 100 gpon 0/1/0 ont 1 gemport 14 multi-service user-vlan 45 tag-transform translate-and-add
inner-vlan 1001 inbound traffic-table name ftth_hsi outbound traffic-table name ftth_hsi
huawei(config)#service-port vlan 100 gpon 0/1/0 ont 2 gemport 14 multi-service user-vlan 45 tag-transform translate-and-add
inner-vlan 1002 inbound traffic-table name ftth_hsi outbound traffic-table name ftth_hsi

    6. Save the data.
      huawei(config)#save
  • Configure the HGW.
    1. Log in to the web configuration window.

      1. Enter the default IP address in the address bar of the browser, and then press Enter.
      2. In the login window, enter the user name and password (the default value is provided by ISP) of the administrator and click OK.

    2. Set parameters for the Internet access service.

      1. Choose Internet access service configuration from the navigation tree.
      2. Set parameters for the Internet access service.

        Parameter

        Value

        Bearing service

        Internet

        VLAN enabling

        (Set this parameter when the HGW uses the LAN or VDSL2 for upstream transmission)

        Enabled: VLAN tags are added to upstream packets.

        NOTE:
        When Internet access service flows are created on the OLT, if the value of uservlan is untagged, set this parameter to Disabled; otherwise, set it to Enabled.

        VLANID[1-4094]

        (Set this parameter when the HGW uses the LAN or VDSL2 for upstream transmission)

        The internet VLAN ID on the HGW. In this example, set this parameter to 45.

        VPI/VCI

        (Set this parameter when the HGW uses ADSL2+ for upstream transmission)

        Set the VPI/VCI to be the same as that configured on the devices at the central office. In this example, set this parameter to 0/35.

        Mode

        PPPoE
      3. Submit the configuration.

Parent Topic: Bridging ONT + HGW Network Scenario (GPON and 10G GPON Access)


Configuring the Voice Service

The OLT is connected to the remote ONT through a GPON port to provide users with the IP-based high-quality and low-cost VoIP service.

Prerequisites

  • The SIP interface data and POTS user configuration data corresponding to the MG interface have been configured on the SIP server.
  • The connection between the OLT and the SIP server is set up. The OLT can ping the IP address of the SIP server successfully.
  • The ONT has been added to the OLT. For details, see Adding an ONT to an OLT.
  • HGWs have different models and appearance and therefore, their configuration processes are not the same. This topic describes how to configure the voice service on an HGW. The actual configuration varies depending on different HGWs.
  • The built-in integrated access device (IAD) of the HGW uses SIP as the voice protocol.

Data Plan

Item

Data

ONT line profile

Profile name: ftth

GEM port ID: 12

VLAN plan
Single VLAN tag:
  • VLAN ID: 300
  • VLAN type: smart
  • VLAN attribute: common
  • UVLAN ID: 47
VLAN translation policy:
  • ONT: Packets that are sent upstream by the HGW are tagged with a user VLAN. The ONT transparently transmits the user VLAN.
  • OLT: translates the VLAN tag (user VLAN <-> S-VLAN).

Voice parameter

IP address of the SIP server: 200.200.200.200/24

Port ID of the SIP server: 5060

User phone number: 77730010

Procedure

  • Configure the OLT.
    1. Configure a traffic profile.

      Run the display traffic table ip command to query the existing traffic profiles in the system. If the existing traffic profiles in the system do not meet the requirements, run the traffic table ip command to add a traffic profile.

      Set the profile name to ftth_voip and do not limit the upstream and downstream rates. Set the priority to 5 and packets are scheduled according to the priority carried.

      huawei(config)#traffic table ip name ftth_voip cir off priority 5 priority-policy
 local-setting
    2. Configure the mapping relationship between a GEM port and a VLAN.

      The service flow of user VLAN 47 is mapped to GEM port 12 in the ONT line profile.
      NOTE:
      The user VLAN is the VLAN in the packets sent from the HGW to the ONT, that is, the UVLAN.
      huawei(config)#ont-lineprofile gpon profile-name ftth
huawei(config-gpon-lineprofile-1)#gem mapping 12 2 vlan 47
huawei(config-gpon-lineprofile-1)#commit
huawei(config-gpon-lineprofile-1)#quit

    3. Configure the VLAN of the Ethernet port on the ONT.

      If the ONT is connected to the HGW through Ethernet port 1, add Ethernet port 1 to VLAN 47 in the ONT service profile.

      huawei(config)#ont-srvprofile gpon profile-name ftth
huawei(config-gpon-srvprofile-1)#port vlan eth 1 47
huawei(config-gpon-srvprofile-1)#commit
huawei(config-gpon-srvprofile-1)#quit

    4. Create a service VLAN and add an upstream port to it.

      Add upstream port 0/19/0 to VLAN 300.

      huawei(config)#vlan 300 smart
huawei(config)#port vlan 300 0/19 0

    5. Create service flows.

      Set the service VLAN to 300, GEM port ID to 12, and user VLAN to 47, and use traffic profile ftth_voip.

      huawei(config)#service-port vlan 300 gpon 0/1/0 ont 1 gemport 12 multi-service
user-vlan 47 inbound traffic-table name ftth_voip outbound traffic-table name ftth_voip
huawei(config)#service-port vlan 300 gpon 0/1/0 ont 2 gemport 12 multi-service
user-vlan 47 inbound traffic-table name ftth_voip outbound traffic-table name ftth_voip

    6. Enable the ARP proxy function.

      Voice media streams for different users of the same SVLAN fail to interchange because the service ports of the smart VLAN are isolated from each other. Therefore, the ARP proxy function needs to be enabled on the OLT.

      huawei(config)#arp proxy enable
huawei(config)#interface vlanif 300
huawei(config-if-vlanif300)#arp proxy enable
huawei(config-if-vlanif300)#quit
    7. Save the data.
      huawei(config)#save
  • Configure the HGW.
    1. Log in to the web configuration window.

      1. Enter the default IP address in the address bar of the browser, and then press Enter.
      2. In the login window, enter the user name and password (the default value is provided by ISP) of the administrator and click OK.

    2. Set parameters of the voice service.

      1. Choose the voice service configuration from the navigation tree.
      2. Set parameters of the voice service.

        Parameter

        Value

        Bearing service

        VoIP

        Enabling status

        Enabled

        VLAN enabling

        (Set this parameter when the HGW uses the LAN or VDSL2 for upstream transmission)

        Enabled: VLAN tags are added to upstream packets.

        NOTE:
        When voice service flows are created on the OLT, if the value of uservlan is untagged, set this parameter to Disabled; otherwise, set it to Enabled.

        VLANID[1-4094]

        (Set this parameter when the HGW uses the LAN or VDSL2 for upstream transmission)

        The voice VLAN ID on the HGW. In this example, set this parameter to 47.

        VPI/VCI

        (Set this parameter when the HGW uses ADSL2+ for upstream transmission)

        Set the VPI/VCI to be the same as that configured on the devices at the central office. In this example, set this parameter to 0/35.

        802.1p

        Enabled

        Mode

        Route: Route mode

        DHCP

        Enabled
      3. Choose the voice telephone number configuration from the navigation tree. Set the parameters as follows:

        Parameter

        Value

        Address

        Preferred IP address of the proxy server: 200.200.200.200

        Port ID

        Preferred signaling port ID of the proxy server: 5060

        Enabled

        Enabled

        User number

        To use the VoIP account, you can set the account to the user telephone number. In this example, set the user telephone number to 77730010.

        User password

        -
      4. Submit the configuration.

Parent Topic: Bridging ONT + HGW Network Scenario (GPON and 10G GPON Access)


Configuring the BTV Service

The OLT is connected to the remote bridging ONT through a GPON port to provide users with the multicast service.

Prerequisites

  • The OLT is connected to the BRAS and the multicast source.
  • The VLAN of the LAN switch port connected to the OLT is the same as the upstream VLAN of the OLT.
  • The ONT has been added to the OLT. For details, see Adding an ONT to an OLT.
  • HGWs have different models and appearance and therefore, their configuration processes are not the same. This topic describes how to configure the Internet access service on an HGW generally. The actual configuration varies depending on different HGWs.

Data Plan

Item

Data

ONT line profile

Profile name: ftth

GEM port ID: 13

Traffic profile

ID: 8

802.1p priority: 4

CIR: off (unlimited)

Priority-based scheduling policy: local-setting

VLAN Plan

Single VLAN tag:
  • SVLAN ID: 1000
  • HGW VLAN: 43
  • MVLAN ID: 1000
  • VLAN type: smart
  • VLAN attribute: common
VLAN translation policy:
  • ONT: translates the upstream VLAN of the HGW to an MVLAN.
  • OLT: duplicates multicast packets based on PON ports with MVLAN unchanged.

Multicast service data

Multicast protocol: IGMP proxy

Multicast version: IGMPv2

Multicast program: dynamic obtaining mode

Procedure

  • Configure the OLT.
    1. Configure a traffic profile.

      Set the profile name to ftth_iptv. Set the CIR to off (unlimited), priority to 4, and priority-based scheduling policy to local-setting (that is, queues are scheduled based on the priority specified in the profile).

      NOTE:
      Run the display traffic table ip command to query the existing traffic profiles in the system. If the existing traffic profiles in the system do not meet the requirements, run the traffic table ip command to add a traffic profile.

      huawei(config)#traffic table name ftth_iptv cir off priority 4 priority-policy local-setting
    2. Configure the mapping relationship between a GEM port and a VLAN.

      If the ONT is connected to the HGW through Ethernet port 2, map the service flow of Ethernet port 2 to GEM port 13 in the ONT line profile.

      huawei(config)#ont-lineprofile gpon profile-name ftth
huawei(config-gpon-lineprofile-1)#gem mapping 13 2 vlan 1000
huawei(config-gpon-lineprofile-1)#commit
huawei(config-gpon-lineprofile-1)#quit

    3. Configure a VLAN translation policy for the Ethernet port on the ONT.

      If the ONT is connected to the HGW through Ethernet port 2, VLAN 43 of the HGW is translated to VLAN 1000 and the MVLAN of the ONT is translated to VLAN 1000.

      huawei(config)#ont-srvprofile gpon profile-name ftth
huawei(config-gpon-srvprofile-1)#port vlan eth 2 translation 1000 user-vlan 43
huawei(config-gpon-srvprofile-1)#multicast-forward tag translation 43
huawei(config-gpon-srvprofile-1)#commit
huawei(config-gpon-srvprofile-1)#quit

    4. Create a service VLAN and add an upstream port to it.

      Add upstream port 0/19/0 to VLAN 1000.

      huawei(config)#vlan 1000 smart
huawei(config)#port vlan 1000 0/19 0

    5. Create service flows.

      Set the service VLAN to 1000, GEM port ID to 13, and user VLAN to 1000, and use traffic profile ftth_iptv.

      huawei(config)#service-port vlan 1000 gpon 0/1/0 ont 1 gemport 13 multi-service
user-vlan 1000 inbound traffic-table name ftth_iptv outbound traffic-table name ftth_iptv
huawei(config)#service-port vlan 1000 gpon 0/1/0 ont 2 gemport 13 multi-service
user-vlan 1000 inbound traffic-table name ftth_iptv outbound traffic-table name ftth_iptv

    6. Create an MVLAN and configure the IGMP version.

      Set the IGMP version for the MVLAN to IGMPv2.

      huawei(config)#multicast-vlan 1000
huawei(config-mvlan1000)#igmp version v2
  This operation will delete all IPv4 programs with source IP addresses in the
current multicast VLAN
  Are you sure to change current IGMP version? (y/n)[n]:y
  Command is being executed. Please wait...
  Command has been executed successfully
    7. Configure a program library.

      Set the mode for obtaining multicast programs to dynamic.
      NOTE:

      You can set the mode for obtaining multicast programs to dynamic only when the IGMP mode is off.

      huawei(config-mvlan1000)#igmp mode off
  Are you sure to close IGMP? (y/n)[n]:y
  Command is being executed. Please wait...
  Command has been executed successfully

huawei(config-mvlan1000)#igmp match mode disable
  Command has been executed successfully

      (Optional) Set the address range for the dynamic programs. If you need to limit the address range of dynamic programs, perform this operation. For example, set the address range of dynamic programs to 224.1.1.1-224.1.1.100.

      huawei(config-mvlan1000)#igmp match group ip 224.1.1.1 to-ip 224.1.1.100

    8. Set the IGMP mode.

      Select the IGMP proxy mode.

      huawei(config-mvlan1000)#igmp mode proxy
  Are you sure to change IGMP mode? (y/n)[n]:y
  Command is being executed. Please wait...
  Command has been executed successfully
    9. (Optional) Configure the IGMP upstream port.

      In this example, the IGMP upstream port uses default value default.

      Run the display igmp config global command to query the IGMP upstream port mode. If this mode does not meet the requirement, run the igmp uplink-port-mode command to configure it.

    10. Configure multicast users.

      Add service ports 1 and 2 as multicast users.

      huawei(config-mvlan1000)#btv
huawei(config-btv)#igmp user add service-port 1
huawei(config-btv)#igmp user add service-port 2
huawei(config-btv)#multicast-vlan 1000
huawei(config-mvlan1000)#igmp multicast-vlan member service-port 1
huawei(config-mvlan1000)#igmp multicast-vlan member service-port 2
huawei(config-mvlan1000)#quit
    11. Save the data.
      huawei(config)#save
  • Configure the HGW.
    1. Log in to the web configuration window.

      1. Enter the default IP address in the address bar of the browser, and then press Enter.
      2. In the login window, enter the user name and password (the default value is provided by ISP) of the administrator and click OK.

    2. Set parameters for the BTV service.

      1. Choose BTV service configuration from the navigation tree.
      2. Set parameters for the BTV service.

        Parameter

        Value

        Bearing service

        OTHER: It is used for the BTV service.

        VLAN enabling

        (Set this parameter when the HGW uses the LAN or VDSL2 for upstream transmission)

        Enabled: VLAN tags are added to upstream packets.

        NOTE:
        When BTV service flows are configured on the OLT, if the value of uservlan is untagged, set this parameter to Disabled; otherwise, set it to Enabled.

        VLANID[1-4094]

        (Set this parameter when the HGW uses the LAN or VDSL2 for upstream transmission)

        The BTV VLAN ID on the HGW. In this example, set this parameter to 43.

        VPI/VCI

        (Set this parameter when the HGW uses ADSL2+ for upstream transmission)

        Set the VPI/VCI to be the same as that configured on the devices at the central office. In this example, set this parameter to 0/35.

        Binding item

        LAN3 (Example: LAN3 interface serves as the BTV interface)

        Mode

        Bridge

        DHCP transparent transmission

        Enabled
      3. Submit the configuration.

Parent Topic: Bridging ONT + HGW Network Scenario (GPON and 10G GPON Access)


Configuring the VoD Service

The OLT is connected to the remote bridging ONT through a GPON port to provide users with the VoD service.

Prerequisites

  • The OLT is connected to the BRAS and the program source.
  • The VLAN of the LAN switch port connected to the OLT is the same as the upstream VLAN of the OLT.
  • The ONT has been added to the OLT. For details, see Adding an ONT to an OLT.
  • HGWs have different models and appearance and therefore, their configuration processes are not the same. This topic describes how to configure the Internet access service on an HGW generally. The actual configuration varies depending on different HGWs.

Data Plan

Item

Data

ONT line profile

Profile name: ftth

T-CONT ID: 4

GEM port ID: 13

Traffic profile

ID: 8

802.1p priority: 4

CIR: off (unlimited)

Priority-based scheduling policy: local-setting

VLAN Plan
Single VLAN tag:
  • SVLAN ID: 1000
  • VLAN type: smart
  • VLAN attribute: common
  • UVLAN (upstream VLAN of the HGW): 41
  • CVLAN=UVLAN
VLAN translation policy:
  • ONT: transparently transmits the UVLAN of the HGW.
  • OLT: implements VLAN translation: U<->S.

Procedure

  1. Configure the OLT.
    1. Configure a traffic profile.

      Set the profile name to ftth_iptv. Set the CIR to off (unlimited), priority to 4, and priority-based scheduling policy to local-setting (that is, queues are scheduled based on the priority specified in the profile).

      NOTE:
      Run the display traffic table ip command to query the existing traffic profiles in the system. If the existing traffic profiles in the system do not meet the requirements, run the traffic table ip command to add a traffic profile.

      huawei(config)#traffic table name ftth_iptv cir off priority 4 priority-policy local-setting
    2. Configure the mapping relationship between a GEM port and a VLAN.

      The service flow of user VLAN 41 is mapped to GEM port 13 in the ONT line profile.

      huawei(config)#ont-lineprofile gpon profile-name ftth
huawei(config-gpon-lineprofile-1)#gem mapping 13 4 vlan 41
huawei(config-gpon-lineprofile-1)#commit
huawei(config-gpon-lineprofile-1)#quit

    3. Configure the VLAN of the Ethernet port on the ONT.

      If the ONT is connected to the HGW through Ethernet port 2, add Ethernet port 2 to VLAN 41.

      huawei(config)#ont-srvprofile gpon profile-name ftth
huawei(config-gpon-srvprofile-1)#port vlan eth 2 41
huawei(config-gpon-srvprofile-1)#commit
huawei(config-gpon-srvprofile-1)#quit

    4. Create a service VLAN and add an upstream port to it.

      Add upstream port 0/19/0 to VLAN 1000.

      huawei(config)#vlan 1000 smart
huawei(config)#port vlan 1000 0/19 0

    5. Create service flows.

      Set the service VLAN to 1000, GEM port ID to 13, and user VLAN to 41, and use traffic profile ftth_iptv.

      huawei(config)#service-port vlan 1000 gpon 0/1/0 ont 1 gemport 13 multi-service user-vlan 41 inbound traffic-table name ftth_iptv
outbound traffic-table name ftth_iptv
huawei(config)#service-port vlan 1000 gpon 0/1/0 ont 2 gemport 13 multi-service user-vlan 41 inbound traffic-table name ftth_iptv
outbound traffic-table name ftth_iptv

    6. Save the data.
      huawei(config)#save
  2. Configure the HGW.
    1. Log in to the web configuration window.

      1. Enter the default IP address in the address bar of the browser, and then press Enter.
      2. In the login window, enter the user name and password (the default value is provided by ISP) of the administrator and click OK.

    2. Set parameters for the VoD service.

      1. Choose VoD service configuration from the navigation tree.
      2. Set parameters for the VoD service.

        Parameter

        Value

        Bearing service

        OTHER: It is used for the VoD service.

        VLAN enabling

        (Set this parameter when the HGW uses the LAN or VDSL2 for upstream transmission)

        Enabled: VLAN tags are added to upstream packets.

        NOTE:
        When VoD service flows are configured on the OLT, if the value of uservlan is untagged, set this parameter to Disabled; otherwise, set it to Enabled.

        VLANID[1-4094]

        (Set this parameter when the HGW uses the LAN or VDSL2 for upstream transmission)

        The VoD VLAN ID on the HGW. In this example, set this parameter to 41.

        VPI/VCI

        (Set this parameter when the HGW uses ADSL2+ for upstream transmission)

        Set the VPI/VCI to be the same as that configured on the devices at the central office. In this example, set this parameter to 0/35.

        Binding item

        LAN4 (Example: LAN4 interface serves as the VoD interface)

        Mode

        Bridge

        DHCP transparent transmission

        Enabled
      3. Submit the configuration.

Parent Topic: Bridging ONT + HGW Network Scenario (GPON and 10G GPON Access)


Configuring Link Aggregation, Congestion Control, and Security Policy

The global configuration of link aggregation and queue scheduling based on priorities ensures service reliability. The global configuration of security policies ensures service security.

Context

Link aggregation provides a higher bandwidth and uplink reliability for optical line terminals (OLTs) by aggregating multiple uplink Ethernet ports to one link aggregation group (LAG).

Congestion control places the packets to be sent from a port into multiple queues that are marked with different priorities. Then, the packets are sent based on queue priorities.

Security policies ensure system, user, and service security.
NOTE:
Enable a service security function based on the service type. For details, see Principle of Security Data Plan.

Procedure

  • Configure link aggregation.

    The following configurations are used as an example to configure link aggregation:

    • Uplink ports 0/19/0 and 0/19/1 are added to a LAG.
    • The two ports send packets upstream based on the packets' source MAC addresses.
    • The LAG works in Link Aggregation Control Protocol (LACP) static aggregation mode.
    huawei(config)#link-aggregation 0/19 0-1 ingress workmode lacp-static

  • Configure queue scheduling.

    According to quality of service (QoS) planning principles, all packets are scheduled in strict priority (SP) mode and mapped to queues according to the packets' priorities. For details about QoS planning principles, see Principle of QoS Planning.

    huawei(config)#queue-scheduler strict-priority
huawei(config)#cos-queue-map cos0 0 cos4 4 cos5 5 cos6 6

  • Configure system security.
    • Enable deny of service (DoS) anti-attack on the OLT.
      1. Run the security anti-dos enable command to globally enable DoS anti-attack.
      2. Run the security anti-dos control-packet policy command to configure a protocol packet processing policy that will be used when a DoS attack occurs.
      3. Run the security anti-dos control-packet rate command to configure the threshold for the rate of sending protocol packets to the CPU.
    • Enable IP address anti-attack on the OLT.

      Run the security anti-ipattack enable command to enable IP address anti-attack.

  • Configure user security.
    • Enable MAC address anti-flapping on the OLT.

      Run the security anti-macduplicate enable command to enable MAC address anti-flapping.

    • Enable MAC address anti-spoofing on the OLT.
      1. In global config mode, run the security anti-macspoofing enable command to globally enable MAC address anti-spoofing.
      2. Enable MAC address anti-spoofing at VLAN level in global config mode or service profile mode:
        1. In global config mode, run the security anti-macspoofing vlan command to enable MAC address anti-spoofing.
        2. In global config mode, run the vlan service-profile command to create a VLAN service profile.
        3. Perform the following operations to enable MAC address anti-spoofing in VLAN service profile mode:
          1. Run the security anti-macspoofing enable command to enable MAC address anti-spoofing at VLAN level.
          2. Run the commit command to make the profile configuration take effect.
          3. Run the quit command to quit the VLAN service profile mode.
          4. Run the vlan bind service-profile command to bind the created VLAN service profile to a VLAN.
      3. (Optional) Run the security anti-macspoofing max-mac-count command to set the maximum number of MAC addresses that can be bound to a service flow.
      4. (Optional) Run the security anti-macspoofing exclude command to configure the types of packets for which MAC address anti-spoofing does not take effect, such as Internet Group Management Protocol (IGMP) packets.
    • Enable IP address anti-spoofing on the OLT.
      IP address anti-spoofing can be enabled or disabled at three levels: global, VLAN, and service port levels. This function takes effect only after it is enabled at the three levels. Among the three levels, IP address anti-spoofing is disabled only at the global level by default.
      1. In global config mode, run the security anti-ipspoofing enable command to enable IP address anti-spoofing at the global level.
      2. In VLAN service profile mode, run the security anti-ipspoofing enable command to enable IP address anti-spoofing at the VLAN level.
      3. Run the security anti-ipspoofing service-port serviceport-id enable command to enable IP address anti-spoofing at the service port level.
  • Configure service security.
    • Enable Dynamic Host Configuration Protocol (DHCP) Option 82 on the OLT. This configuration is recommended for the DHCP-based Internet access service.
      1. Enable DHCP Option 82 on the OLT.

        DHCP Option 82 can be enabled or disabled at four levels: global, port, VLAN, and service port levels. This function takes effect only after it is enabled at the four levels. Among the four levels, DHCP Option 82 is disabled only at the global level by default.

        • The global level: In global config mode, run the dhcp option82 command to enable DHCP Option 82 at the global level.

          When you run this command, select the enable, forward, or rebuild parameter based on site requirements. The three parameters can all enable DHCP Option 82 but provide different packet processing policies on the OLT. For details, see the dhcp option82 command.

        • The port level: In global config mode, run the dhcp option82 port or dhcp option82 board command to enable DHCP Option 82 at the port level.
        • The VLAN level:
          1. In global config mode, run the vlan service-profile command to create a VLAN service profile.
          2. Run the dhcp option82 enable command to enable DHCP Option 82 at the VLAN level.
          3. Run the commit command to make the profile configuration take effect.
          4. Run the quit command to quit the VLAN service profile mode.
          5. Run the vlan bind service-profile command to bind the created VLAN service profile to a VLAN.
        • The service port level: In global config mode, run the dhcp option82 service-port command to enable DHCP Option 82 at the service port level.
      2. On the OLT, run the dhcp-option82 permit-forwarding service-port command with the enable parameter selected, to allow ONT DHCP packets to carry Option 82 information.
    • Enable Policy Information Transfer Protocol (PITP) on the OLT. This configuration is recommended for the PPPoE-based Internet access service.
      1. Enable PITP on the OLT.

        PITP can be enabled or disabled at four levels: global, port, VLAN, and service port levels. This function takes effect only after it is enabled at the four levels. Among the four levels, PITP is disabled only at the global level by default.

        • The global level: In global config mode, run the pitp enable pmode, pitp forward pmode, or pitp rebuild pmode command to enable PITP at the global level.

          In the preceding commands, the enable, forward, and rebuild parameters can all enable PITP but provide different packet processing policies on the OLT. Select one of them based on site requirements. For details, see the pitp command.

        • The port level: In global config mode, run the pitp port or pitp board command to enable PITP at the port level.
        • The VLAN level:
          1. In global config mode, run the vlan service-profile command to create a VLAN service profile.
          2. Run the pitp enable command to enable PITP at the VLAN level.
          3. Run the commit command to make the profile configuration take effect.
          4. Run the quit command to quit the VLAN service profile mode.
          5. Run the vlan bind service-profile command to bind the created VLAN service profile to a VLAN.
        • The service port level: In global config mode, run the pitp service-port command to enable PITP at the service port level.
      2. On the OLT, run the pitp permit-forwarding service-port command with the enable parameter selected, to allow ONT PPPoE packets to carry a vendor tag.
Parent Topic: Bridging ONT + HGW Network Scenario (GPON and 10G GPON Access)


Verifying Services

In the FTTH scenario, ONTs are installed in users' houses which are far away from the central equipment room. ONTs provide remote service verification methods including PPPoE dialup emulation, call emulation, and multicast emulation to facilitate configuration and commissioning engineers to verify services remotely after service configuration.

Prerequisites

ONTs and upper-layer devices have been connected properly. The BRAS and MGC/IMS have been configured.

Background

Remote Service Verification Method

Function

Description

PPPoE dialup emulation

An ONT simulates a PPPoE user terminal software to perform dialup and interact with the BRAS to verify the connectivity between the ONT and BRAS.
  • PPPoE dialup emulation requires a service flow which does not belong to a QinQ VLAN.
  • A user name, password, and authentication mode must be configured on the BRAS for the PPPoE dialup emulation.
  • An ONT supports a maximum of a PPPoE dialup emulation.

Call Emulation

An ONT simulates a voice user to make a call to check whether the voice service data is correctly configured. You can also use the call emulation function to locate a fault when the voice service is faulty.
  • An ONT can simulate a caller or callee to communicate with a phone in a call. In this case, only a functional phone is required in the central office where the acceptance personnel is.
  • An ONT supports a maximum of a call emulation.

Multicast emulation

This function enables you to simulate a multicast user going online and lead the program stream to an ONT. You can check whether the multicast service is normal by checking the real-time traffic of the multicast program.

Multicast services configured in the dynamic controllable multicast mode do not support this function.

Data plan

Item | Data | Remarks
PPPoE dialup emulation parameters | PPPoE user name: test@huawei Password: test1234 | The user name, password, and authentication mode for the emulation test must be configured on the BRAS. The entered user name, password, and authentication mode must be consistent with those configured on the BRAS.
Call emulation parameters | ONT POTS ID: 1 | The default values are used. You can run the display pots emulational configuration command to check the parameter values.
Multicast emulation parameters | Multicast service flow ID: 1 MVLAN: 1000 IP address of the multicast program: 224.1.1.10 | -

Procedure

  • Verify the Internet access service using PPPoE dialup emulation.
    1. In the xPON board mode, run the pppoe simulate start command to start a PPPoE dialup emulation test. The following test uses GPON as an example:
      huawei(config)#interface gpon 0/1
huawei(config-if-gpon-0/1)#pppoe simulate start
{ portid<U><0,7> }:0
{ ontid<U><0,127> }:1
{ eth<K>|untagged<K>|vlanid<U><0,4095> }:eth
{ ont-portid<U><1,8> }:4
{ untagged<K>|vlanid<U><0,4095> }:100
{ priority<U><0,7>|user-name<K> }:user-name
{ username<S><Length 1-64> }:test@huawei
{ user-password<K> }:user-password
{ password<S><Length 1-64> }:test1234
{ authentication-mode<K> }:authentication-mode
{ protocol<E><chap,pap> }:chap

  Command:
          pppoe simulate start 0 1 eth 4 100 user-name test@huawei user-password
 test authentication-mode chap

huawei(config-if-gpon-0/1)#
  ----------------------------------
  ONT PPPoE Test Result
  ----------------------------------
  F/S/P                : 0/1/0
  ONT-ID               : 1
  ONT ETH Port ID      : 4
  ONT Vlan ID          : 100
  Vlan Priority        : -
  Emluator result      : Success
  Session ID           : 18814
  User IP              : 192.168.100.101
  Gateway IP           : 192.168.100.1
  ----------------------------------
  • Troubleshooting methods for the Internet access service
    1. Check whether configurations are complete on the OLT.

      • Run the display ont info command to query the ONT status to check whether the ONT is registered successfully.
      • Run the display service-port command to check whether the Internet access service flow is configured and whether the inner VLAN ID of the service flow is consistent with that in the data plan.
      • If a native VLAN is configured for the Ethernet port on the ONT, run the display ont port attribute command in the xPON board mode to check whether the native VLAN is correct.

    2. Check the upstream and downstream ports by checking the MAC address learning status.

      1. Run the display mac-address vlan command to check the MAC address learning status of the Internet service VLAN.
        • If the upstream port does not learn a MAC address, check the network connections between the upstream port and upper-layer devices and check the configurations of upper-layer devices.
        • If the downstream port does not learn a MAC address, check whether the ONT is activated, whether the PC is connected to the right port on the ONT, and whether the PC is working properly.
      2. Run the display ont-learned-mac command to check whether the ONT connecting to the PON port learned any MAC addresses.

        If not, check whether the ONT properly connects to the PC or home gateway (HGW).

  • Verify the voice service using call emulation.
    1. Run the ont emulational call command to configure a call emulation test.
      huawei(config)#test
huawei(config-test)#ont emulational call caller-port 0/1/0 1 1 telno 77730020
{ <cr>|caller-stop-time<K> }:

  Command:
          ont emulational call caller-port 0/1/0 1 1 telno 77730020
    2. The ONT outputs the call emulation result after the test is complete.
      huawei(config-test)#
  ----------------------------------------------------------------
  F/S/P                : 0/1/0
  ONT-ID               : 0
  ONT-POTSID           : 1
  Test type            : caller emulational call test
  Detected number      : 77730020
  Reported number      : 77730020
  Current status       : test end
  Test Result          : success
  ----------------------------------------------------------------
  • Troubleshooting methods for the voice service.
    1. Check whether configurations are complete on the OLT.

      • Run the display ont info command to query the ONT status to check whether the ONT is registered successfully.
      • Run the display service-port command to check whether the voice service flow is configured and whether the inner VLAN ID of the service flow is consistent with that in the data plan.

    2. Check the upstream and downstream ports by checking the MAC address learning status.

      Run the display mac-address vlan command to check the MAC address learning status of the voice service VLAN.
      • If the upstream port does not learn a MAC address, check the network connections between the upstream port and upper-layer devices and check the configurations of upper-layer devices.
      • If the downstream port does not learn a MAC address, check whether the ONT is activated and whether physical links are normal.
      • If both the upstream and downstream ports can learn the MAC address, record the MAC address of the ONT and log in to the service router (SR) to check whether an IP address is allocated to the MAC address.

    3. Check the registration status of the voice service.

      • You can run the display ont port state command on the OLT to query the call connection status on the POTS port. If Call State is RegisterFail or Connecting for a long time, check whether the voice configuration on the MGC/SIP server is consistent with that on the ONT.
      • If the ONT uses the H.248 protocol, you can run the display ont mg status command on the OLT to query the registration status of the MG interface that connects to the ONT. If MG Status is UnRegistered or Registering for a long time, check whether the voice configuration on the MGC/SIP server is consistent with that on the ONT.
      • You can query the registration status of the voice service on the ONT web page. If the query result shows that the registration fails or the voice service is in the registering state for a long time, check whether the voice configuration on the MGC/SIP server is consistent with that on the ONT.

  • Verify the multicast service using multicast emulation.
    1. Run the igmp static-join command to simulate a multicast user to order a multicast program.
      huawei(config)#btv
huawei(config-btv)#igmp static-join service-port 1 ip 224.1.1.10 vlan 1000
      NOTE:
      If the multicast program is obtained dynamically, igmp static-join can be executed successfully only when the range for obtaining the dynamic program is set.
    2. Run the display igmp user command to query the status of the multicast user.
      huawei(config-btv)#display igmp user service-port 1
  User                       : 0/1/0/1
  State                      : online
  Authentication             : no-auth
  Quick leave                : MAC-based
  IGMP flow ID               : 1
  Video flow ID              : 1
  Log switch                 : enable
  Bind profiles              : -
  IGMP version               : IGMP v3
  Current version            : IGMP v3
  Current IGMP IPv6 version  : IGMP IPv6 v2
  Available programs         : 8
  Global leave               : disable
  User max bandwidth         : no-limit
  Used bandwidth(kbps)       : 0
  Used bandwidth
  to max bandwidth(%)        : -
  Total video bandwidth      : -
  Mcast video bandwidth      : -
  Active program list
  ---------------------------------------------------------------------------
  Program name     VLAN  IP/MAC           State           Start time
  ---------------------------------------------------------------------------
  PROGRAM-5        1000  224.1.1.10       watching        2011-10-29
                                                          16:33:41+08:00
  ---------------------------------------------------------------------------
  Total: 1
    3. Run the display multicast flow-statistic command to query the real-time traffic of the multicast program.
      huawei(config-btv)#display multicast flow-statistic vlan 1000 ip 224.1.1.10
{ <cr>|sourceip<K> }:

  Command:
          display multicast flow-statistic vlan 1000 ip 224.1.1.10
  Command is being executed. Please wait...
  Multicast flow statistic result: 8736(kbps)
Parent Topic: Bridging ONT + HGW Network Scenario (GPON and 10G GPON Access)
Huawei Proprietary and Confidential Copyright © Huawei Technologies Co., Ltd.
Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.
< Previous topic


Configuring FTTH IPv6 Services in Bridging-type ONT Scenario (Dual Stack/DS-Lite)

This topic describes how to configure FTTH IPv6 services when the ONT is a bridging-type ONT and the dual stack or DS-Lite solution is used.

Dual Stack Application Scenario

Networking description:
  • All NEs must support both IPv4 and IPv6.
  • The BRAS directly assigns IPv4 and IPv6 addresses to PCs, and the ONT transparently transmits IPv4 and IPv6 packets.
  • PCs use IPv4 and IPv6 addresses to access the IPv4 Internet and IPv6 Internet respectively.
  • Both the OLT and ONT implements Layer 2 forwarding. Only IPv6 service flows need to be added.

Device reconstruction: All NEs on the network need to be upgraded to support IPv4 and IPv6 dual stacks.

Figure 1 shows the dual-stack networking diagram.

Figure 1 Dual-stack networking diagram

DS-Lite Application Scenario

Networking description:
  • Devices below the DS-Lite CGN must support the IPv6 single stack.
  • The BRAS directly assigns IPv6 address prefixes (without IPv4 address) to PCs, and the ONT transparently transmits IPv6 packets.
  • IPv4 addresses are encapsulated into IPv6 packets for forwarding, decapsulated on the DS-Lite CGN, and forwarded to the IPv4 Internet after NAT44 translation. IPv6 addresses are directly forwarded to the IPv6 Internet through IPv6 devices.
  • Both the OLT and ONT implements Layer 2 forwarding. Only IPv6 service flows need to be added.
Device reconstruction:
  • A special software needs to be installed on the PC to support DS-Lite.
  • The CGN needs to be upgraded to support DS-Lite.
  • Devices between the CGN and PC need to be upgraded to support IPv6.
  • The DS-Lite CGN device needs to be added.

Figure 2 shows the DS-Lite networking diagram.

Figure 2 DS-Lite networking diagram

Procedure

  • Configuration using the U2000

    NOTE:

    In the dual stack and DS-Lite scenarios, both the OLT and ONT implement Layer 2 transparent transmission. Configurations in the FTTH scenario are the same as those for IPv4.

    When the access mode of IPv6 users is IPoE and the BRAS uses the binding authentication mode, users do not need to enter user names or passwords for authentication because the BRAS performs authentication based on users' physical information. In this case, DHCPv6 Option18 needs to be configured on the OLT. For the mapping relationship between DHCPv6 Option and the BRAS, see Table 1.

    Table 1 DHCPv6 Option mapping

    DHCPv6 Option

    OLT

    BRAS

    Option17

    N/A

    Optional

    Option18

    Mandatory

    Mandatory

    Option37

    Optional

    Optional
    NOTE:

    By default, the global DHCPv6 Option configuration is disable, the VLAN-level DHCPv6 Option configuration is enable, and the upstream/cascaded port-level DHCPv6 Option configuration is enable. Therefore, you only need to enable DHCPv6 Option globally.

    After DHCPv6 Option is enabled, the OLT inserts Option18 and Option37 into DHCPv6 packets for authentication by the BRAS.

    1. In the Main Topology, double-click the required OLT in the Physical Root navigation tree; or right-click the required OLT and choose NE Explorer from the shortcut menu.
    2. Choose GPON > GPON Management from the navigation tree.
    3. On the GPON ONU tab page, set the filter criteria or click [image] to display the GPON ONUs.
    4. Right-click a required ONT and choose Configure DHCPv6–Option Permit-Forwarding.
    5. In the dialog box that is displayed, select Enable.

    6. Click OK.

  • Configuration using OLT commands

    NOTE:

    In the dual stack and DS-Lite scenarios, both the OLT and ONT implement Layer 2 transparent transmission. Configurations in the FTTH scenario are the same as those for IPv4.

    When the access mode of IPv6 users is IPoE and the BRAS uses the binding authentication mode, users do not need to enter user names or passwords for authentication because the BRAS performs authentication based on users' physical information. In this case, DHCPv6 Option18 needs to be configured on the OLT. Table 2 describes the mapping between the BRAS, OLT, and DHCPv6 Option.

    Table 2 DHCPv6 Option mapping

    DHCPv6 Option

    OLT

    BRAS

    Option17

    N/A

    Optional

    Option18

    Mandatory

    Mandatory

    Option37

    Optional

    Optional
    NOTE:

    By default, the global DHCPv6 Option configuration is disable, the VLAN-level DHCPv6 Option configuration is enable, and the upstream/cascaded port-level DHCPv6 Option configuration is enable. Therefore, you only need to enable DHCPv6 Option globally.

    After DHCPv6 Option is enabled, the OLT inserts Option18 and Option37 into DHCPv6 packets for authentication by the BRAS.

    huawei(config)#raio-mode common dhcpv6-option
huawei(config)#dhcpv6 option enable

  • The ONT implements Layer 2 transparent transmission. Therefore, no configuration needs to be performed on the ONT Web page.
Parent Topic: Configuring the Bridging-Type ONT (HG8010H/HG8040H/HG8050P/HG8012H)
Huawei Proprietary and Confidential Copyright © Huawei Technologies Co., Ltd.
Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.
< Previous topic


GPON Access: Adding an ONT to an OLT.

< Home

Adding an ONT to an OLT

Services can be configured for an ONT only after the ONT is successfully added to an OLT.

Data Plan

Item

Data

DBA profile
Profile name: ftth_dba_mngt
  • Profile type: Type1
  • Fixed bandwidth: 1 Mbit/s
Profile name: ftth_dba_hsi
  • Profile type: Type4
  • Maximum bandwidth: 32 Mbit/s
Profile name: ftth_dba_voip
  • Profile type: Type2
  • Assured bandwidth: 1 Mbit/s
Profile name: ftth_dba_iptv
  • Profile type: Type2
  • Assured bandwidth: 1 Mbit/s

ONT line profile

Profile name: ftth

T-CONT ID for management services: 4

T-CONT ID for voice services: 5

T-CONT ID for video services: 6

T-CONT ID for Internet access services: 7

GEM port ID for management services: 11

GEM port ID for voice services: 12

GEM port ID for video services: 13

GEM port ID for Internet access services: 14

ONT service profile

Profile name: ftth

ONT port capability set: adaptive

Network topology data

PON port: 0/1/0

ONT IDs: 1 and 2

Procedure

  1. Configure GPON ONT profiles.

    GPON ONT profiles include the DBA profile, line profile, service profile, and alarm profile.
    • DBA profile: A DBA profile describes the GPON traffic parameters. A T-CONT is bound to a DBA profile for dynamic bandwidth allocation, improving upstream bandwidth utilization.
    • Line profile: A line profile describes the binding between the T-CONT and the DBA profile, the QoS mode of the traffic stream, and the mapping between the GEM port and the ONT-side service.
    • Service profile: A service profile provides the service configuration channel for the ONT that is managed by using optical network terminal management and control interface (OMCI).
    • Alarm profile: An alarm profile contains a series of alarm thresholds to measure and monitor the performance of activated ONT lines. When a statistical value reaches the threshold, the host is notified and an alarm is reported to the log host and the NMS.

    1. Configure a DBA profile.

      Run the display dba-profile command to query the existing DBA profiles in the system. If the existing DBA profiles in the system cannot meet the requirements, run the dba-profile add command to add a DBA profile.

      huawei(config)#dba-profile add profile-name ftth_dba_mngt type1 fix 1024
huawei(config)#dba-profile add profile-name ftth_dba_voip type2 assure 1024
huawei(config)#dba-profile add profile-name ftth_dba_iptv type2 assure 1024
huawei(config)#dba-profile add profile-name ftth_dba_hsi type4 max 32768

      NOTE:
      Select a DBA profile of the proper bandwidth type and configure proper bandwidth according to the service types and total user count of the ONT. Note that the sum of the fixed bandwidth and the assured bandwidth must not be greater than the total bandwidth of the PON port.

    2. Configure an ONT line profile.

      Create a GPON ONT line profile, named ftth, and bind it to the DBA profile.

      huawei(config)#ont-lineprofile gpon profile-name ftth
huawei(config-gpon-lineprofile-1)#tcont 4 dba-profile-name ftth_dba_mngt
huawei(config-gpon-lineprofile-1)#tcont 5 dba-profile-name ftth_dba_voip
huawei(config-gpon-lineprofile-1)#tcont 6 dba-profile-name ftth_dba_iptv
huawei(config-gpon-lineprofile-1)#tcont 7 dba-profile-name ftth_dba_hsi
      Create different GEM ports according to different service types, in which
      • GEM port 11 is used to carry management services.
      • GEM port 12 is used to carry voice services.
      • GEM port 13 is used to carry video services.
      • GEM port 14 is used to carry Internet access services.
      huawei(config-gpon-lineprofile-1)#gem add 11 eth tcont 4
huawei(config-gpon-lineprofile-1)#gem add 12 eth tcont 5
huawei(config-gpon-lineprofile-1)#gem add 13 eth tcont 6
huawei(config-gpon-lineprofile-1)#gem add 14 eth tcont 7
      NOTE:
      1. To change the default QoS mode, run the qos-mode command to set the QoS mode to gem-car or flow-car, and run the gem add command to set the index of the traffic profile bound to the GEM port.
      2. When the QoS mode is priority-queue (PQ), the default queue priority is 0; when the QoS mode is flow-car or gem-car, traffic profile 6 is bound to the GEM port by default (no rate limitation).

      After the configurations are complete, run the commit command to apply the parameters settings.

      huawei(config-gpon-lineprofile-1)#commit
huawei(config-gpon-lineprofile-1)#quit
    3. Configure an ONT service profile.

      Create a GPON ONT service profile, named ftth. Configure the capability set of the ETH port and POTS port to adaptive. Then the system automatically adapts to the ONT according to the actual capability of the online ONT.

      huawei(config)#ont-srvprofile gpon profile-name ftth
huawei(config-gpon-srvprofile-1)#ont-port eth adaptive pots adaptive

      After the configurations are complete, run the commit command to apply the parameters setting.

      huawei(config-gpon-srvprofile-1)#commit
huawei(config-gpon-srvprofile-1)#quit
    4. (Optional) Add an alarm profile.

      • The default GPON alarm profile 1 is used. The alarm thresholds for the default alarm profile are 0, which indicates that no alarm is generated.
      • In this example, the default alarm profile is used, and therefore the configuration of the alarm profile is not required.
      • Run the gpon alarm-profile add command to configure a GPON alarm profile, which is used for monitoring the performance of an activated ONT line.

  2. Add an ONT.

    Connect two ONTs to GPON port 0/1/0. Set the ONT IDs to 1 and 2, SNs to 3230313126595540 and 6877687714852901, passwords to 0100000001 and 0100000002, discovery mode for password authentication to once-on, and management mode to OMCI. Bind the two ONTs to ONT line profile ftth and ONT service profile ftth.

    There are two methods of adding an ONT: add an ONT offline and confirm an automatically discovered ONT.

    • Add ONTs offline.

      If the password of an ONT is known, run the ont add command to add an ONT offline.

      huawei(config)#interface gpon 0/1
huawei(config-if-gpon-0/1)#ont add 0 1 password-auth 0100000001 once-on no-aging omci ont-lineprofile-name
 ftth ont-srvprofile-name ftth
huawei(config-if-gpon-0/1)#ont add 0 2 password-auth 0100000002 once-on no-aging omci ont-lineprofile-name
 ftth ont-srvprofile-name ftth

    • Confirm automatically discovered ONTs.

      If the password or SN of an ONT is unknown, run the port portid ont-auto-find command in GPON mode to enable the ONT auto-discovery function of the GPON port. Then, run the ont confirm command to confirm the ONT.

      huawei(config)#interface gpon 0/1
huawei(config-if-gpon-0/1)#port 0 ont-auto-find enable
huawei(config-if-gpon-0/1)#display ont autofind 0
  //After this command is executed, the information about all ONTs connected to the GPON port through optical splitters is displayed.

huawei(config-if-gpon-0/1)#ont confirm 0 ontid 1 sn-auth 3230313126595540 omci ont-lineprofile-name
 ftth ont-srvprofile-name ftth
huawei(config-if-gpon-0/1)#ont confirm 0 ontid 2 sn-auth 6877687714852901 omci ont-lineprofile-name
 ftth ont-srvprofile-name ftth
      NOTE:
      If multiple ONTs of the same type bound to the same line profile or service profile are connected to the same port, you can bulk add ONTs by bulk confirming automatically discovered ONTs to make configuration easier and more efficient. To do so, the preceding command can be modified as follows:
      huawei(config-if-gpon-0/1)#ont confirm 0 all sn-auth omci ont-lineprofile-name ftth
ont-srvprofile-name ftth

    • (Optional) Bind the alarm profile to the ONT.

      The default profile 1 is used in this example.

      huawei(config-if-gpon-0/1)#ont alarm-profile 0 1 profile-id 1
huawei(config-if-gpon-0/1)#ont alarm-profile 0 2 profile-id 1

  3. Check ONT status.

    After an ONT is added, run the display ont info command to query the current status of the ONT. Ensure that Config flag of the ONT is active, Run State is online, Config state is normal, and Match state is match.

    huawei(config-if-gpon-0/1)#display ont info 0 1
  ---------------------------------------------------------------------
  F/S/P                : 0/1/0
  ONT-ID               : 1
  Control flag         : active    //Indicates that the ONT is activated.
  Run state            : online    //Indicates that the ONT goes online successfully.
  Config state         : normal    //Indicates that the configuration state of the ONT is normal.
  Match state          : match     //Indicates that the capability profile bound to the ONT is consistent with the actual capability of the ONT.
...//The rest of the response information is omitted.
    When Config state is failed, Run state is offline, or Match state is mismatch:
    • If Control flag is deactive, run the ont active command in GPON mode to activate the ONU.
    • If Run state is offline, a physical line may be broken or the optical module may be damaged. Check the line and the optical module.
    • If Config state is failed, the configured ONU capability exceeds the actual ONU capability. In this case, run the display ont failed-configuration command in the diagnose mode to check the failed configuration item and the failure cause. Then, rectify the fault accordingly.
    • If the ONU does not match, that is, Match state is mismatch, the port types and number of ports undermatch the actual port types and number of ports supported by the ONU. In this case, run the display ont capability command to query the actual capability of the ONU, and then select one of the following modes to modify the ONU configuration:
      • Create a proper ONU profile according to the actual capability of the ONU, and then run the ont modify command to modify the configuration data of the ONU.
      • Modify the ONU profile according to the actual capability of the ONU and save the modification. Then, the ONU automatically recovers the configuration successfully.


Configuring Link Aggregation, Congestion Control, and Security Policies

The global configuration of link aggregation and queue scheduling based on priorities ensures service reliability. The global configuration of security policies ensures service security.

Context

Link aggregation provides a higher bandwidth and uplink reliability for optical line terminals (OLTs) by aggregating multiple uplink Ethernet ports to one link aggregation group (LAG).

Congestion control places the packets to be sent from a port into multiple queues that are marked with different priorities. Then, the packets are sent based on queue priorities.

Security policies ensure system, user, and service security.
NOTE:
Enable a service security function based on the service type. For details, see Principle of Security Data Plan.

Procedure

  • Configure link aggregation.

    The following configurations are used as an example to configure link aggregation:

    • Uplink ports 0/19/0 and 0/19/1 are added to a LAG.
    • The two ports send packets upstream based on the packets' source MAC addresses.
    • The LAG works in Link Aggregation Control Protocol (LACP) static aggregation mode.
    huawei(config)#link-aggregation 0/19 0-1 ingress workmode lacp-static

  • Configure queue scheduling.

    According to quality of service (QoS) planning principles, all packets are scheduled in strict priority (SP) mode and mapped to queues according to the packets' priorities. For details about QoS planning principles, see Principle of QoS Planning.

    huawei(config)#queue-scheduler strict-priority
huawei(config)#cos-queue-map cos0 0 cos4 4 cos5 5 cos6 6

  • Configure system security.
    • Enable deny of service (DoS) anti-attack on the OLT.
      1. Run the security anti-dos enable command to globally enable DoS anti-attack.
      2. Run the security anti-dos control-packet policy command to configure a protocol packet processing policy that will be used when a DoS attack occurs.
      3. Run the security anti-dos control-packet rate command to configure the threshold for the rate of sending protocol packets to the CPU.
    • Enable IP address anti-attack on the OLT.

      Run the security anti-ipattack enable command to enable IP address anti-attack.

  • Configure user security.
    • Enable MAC address anti-flapping on the OLT.

      Run the security anti-macduplicate enable command to enable MAC address anti-flapping.

    • Enable MAC address anti-spoofing on the OLT.
      1. In global config mode, run the security anti-macspoofing enable command to globally enable MAC address anti-spoofing.
      2. Enable MAC address anti-spoofing at VLAN level in global config mode or service profile mode:
        1. In global config mode, run the security anti-macspoofing vlan command to enable MAC address anti-spoofing.
        2. In global config mode, run the vlan service-profile command to create a VLAN service profile.
        3. Perform the following operations to enable MAC address anti-spoofing in VLAN service profile mode:
          1. Run the security anti-macspoofing enable command to enable MAC address anti-spoofing at VLAN level.
          2. Run the commit command to make the profile configuration take effect.
          3. Run the quit command to quit the VLAN service profile mode.
          4. Run the vlan bind service-profile command to bind the created VLAN service profile to a VLAN.
      3. (Optional) Run the security anti-macspoofing max-mac-count command to set the maximum number of MAC addresses that can be bound to a service flow.
      4. (Optional) Run the security anti-macspoofing exclude command to configure the types of packets for which MAC address anti-spoofing does not take effect, such as Internet Group Management Protocol (IGMP) packets.
    • Enable IP address anti-spoofing on the OLT.
      IP address anti-spoofing can be enabled or disabled at three levels: global, VLAN, and service port levels. This function takes effect only after it is enabled at the three levels. Among the three levels, IP address anti-spoofing is disabled only at the global level by default.
      1. In global config mode, run the security anti-ipspoofing enable command to enable IP address anti-spoofing at the global level.
      2. In VLAN service profile mode, run the security anti-ipspoofing enable command to enable IP address anti-spoofing at the VLAN level.
      3. Run the security anti-ipspoofing service-port serviceport-id enable command to enable IP address anti-spoofing at the service port level.
  • Configure service security.
    • Enable Dynamic Host Configuration Protocol (DHCP) Option 82 on the OLT. This configuration is recommended for the DHCP-based Internet access service.
      1. Enable DHCP Option 82 on the OLT.

        DHCP Option 82 can be enabled or disabled at four levels: global, port, VLAN, and service port levels. This function takes effect only after it is enabled at the four levels. Among the four levels, DHCP Option 82 is disabled only at the global level by default.

        • The global level: In global config mode, run the dhcp option82 command to enable DHCP Option 82 at the global level.

          When you run this command, select the enable, forward, or rebuild parameter based on site requirements. The three parameters can all enable DHCP Option 82 but provide different packet processing policies on the OLT. For details, see the dhcp option82 command.

        • The port level: In global config mode, run the dhcp option82 port or dhcp option82 board command to enable DHCP Option 82 at the port level.
        • The VLAN level:
          1. In global config mode, run the vlan service-profile command to create a VLAN service profile.
          2. Run the dhcp option82 enable command to enable DHCP Option 82 at the VLAN level.
          3. Run the commit command to make the profile configuration take effect.
          4. Run the quit command to quit the VLAN service profile mode.
          5. Run the vlan bind service-profile command to bind the created VLAN service profile to a VLAN.
        • The service port level: In global config mode, run the dhcp option82 service-port command to enable DHCP Option 82 at the service port level.
      2. On the OLT, run the dhcp-option82 permit-forwarding service-port command with the enable parameter selected, to allow ONT DHCP packets to carry Option 82 information.
    • Enable Policy Information Transfer Protocol (PITP) on the OLT. This configuration is recommended for the PPPoE-based Internet access service.
      1. Enable PITP on the OLT.

        PITP can be enabled or disabled at four levels: global, port, VLAN, and service port levels. This function takes effect only after it is enabled at the four levels. Among the four levels, PITP is disabled only at the global level by default.

        • The global level: In global config mode, run the pitp enable pmode, pitp forward pmode, or pitp rebuild pmode command to enable PITP at the global level.

          In the preceding commands, the enable, forward, and rebuild parameters can all enable PITP but provide different packet processing policies on the OLT. Select one of them based on site requirements. For details, see the pitp command.

        • The port level: In global config mode, run the pitp port or pitp board command to enable PITP at the port level.
        • The VLAN level:
          1. In global config mode, run the vlan service-profile command to create a VLAN service profile.
          2. Run the pitp enable command to enable PITP at the VLAN level.
          3. Run the commit command to make the profile configuration take effect.
          4. Run the quit command to quit the VLAN service profile mode.
          5. Run the vlan bind service-profile command to bind the created VLAN service profile to a VLAN.
        • The service port level: In global config mode, run the pitp service-port command to enable PITP at the service port level.
      2. On the OLT, run the pitp permit-forwarding service-port command with the enable parameter selected, to allow ONT PPPoE packets to carry a vendor tag.


Verifying Services

In the FTTH scenario, ONTs are installed in users' houses which are far away from the central equipment room. ONTs provide remote service verification methods including PPPoE dialup emulation, call emulation, and multicast emulation to facilitate configuration and commissioning engineers to verify services remotely after service configuration.

Prerequisites

ONTs and upper-layer devices have been connected properly. The BRAS and MGC/IMS have been configured.

Background

Remote Service Verification Method

Function

Description

PPPoE dialup emulation

An ONT simulates a PPPoE user terminal software to perform dialup and interact with the BRAS to verify the connectivity between the ONT and BRAS.
  • PPPoE dialup emulation requires a service flow which does not belong to a QinQ VLAN.
  • A user name, password, and authentication mode must be configured on the BRAS for the PPPoE dialup emulation.
  • An ONT supports a maximum of a PPPoE dialup emulation.

Call Emulation

An ONT simulates a voice user to make a call to check whether the voice service data is correctly configured. You can also use the call emulation function to locate a fault when the voice service is faulty.
  • An ONT can simulate a caller or callee to communicate with a phone in a call. In this case, only a functional phone is required in the central office where the acceptance personnel is.
  • An ONT supports a maximum of a call emulation.

Multicast emulation

This function enables you to simulate a multicast user going online and lead the program stream to an ONT. You can check whether the multicast service is normal by checking the real-time traffic of the multicast program.

Multicast services configured in the dynamic controllable multicast mode do not support this function.

Data plan

Item | Data | Remarks
PPPoE dialup emulation parameters | PPPoE user name: test@huawei Password: test1234 | The user name, password, and authentication mode for the emulation test must be configured on the BRAS. The entered user name, password, and authentication mode must be consistent with those configured on the BRAS.
Call emulation parameters | ONT POTS ID: 1 | The default values are used. You can run the display pots emulational configuration command to check the parameter values.
Multicast emulation parameters | Multicast service flow ID: 1 MVLAN: 1000 IP address of the multicast program: 224.1.1.10 | -

Procedure

  • Verify the Internet access service using PPPoE dialup emulation.
    1. In the xPON board mode, run the pppoe simulate start command to start a PPPoE dialup emulation test. The following test uses GPON as an example:
      huawei(config)#interface gpon 0/1
huawei(config-if-gpon-0/1)#pppoe simulate start
{ portid<U><0,7> }:0
{ ontid<U><0,127> }:1
{ eth<K>|untagged<K>|vlanid<U><0,4095> }:eth
{ ont-portid<U><1,8> }:4
{ untagged<K>|vlanid<U><0,4095> }:100
{ priority<U><0,7>|user-name<K> }:user-name
{ username<S><Length 1-64> }:test@huawei
{ user-password<K> }:user-password
{ password<S><Length 1-64> }:test1234
{ authentication-mode<K> }:authentication-mode
{ protocol<E><chap,pap> }:chap

  Command:
          pppoe simulate start 0 1 eth 4 100 user-name test@huawei user-password
 test authentication-mode chap

huawei(config-if-gpon-0/1)#
  ----------------------------------
  ONT PPPoE Test Result
  ----------------------------------
  F/S/P                : 0/1/0
  ONT-ID               : 1
  ONT ETH Port ID      : 4
  ONT Vlan ID          : 100
  Vlan Priority        : -
  Emluator result      : Success
  Session ID           : 18814
  User IP              : 192.168.100.101
  Gateway IP           : 192.168.100.1
  ----------------------------------
  • Troubleshooting methods for the Internet access service
    1. Check whether configurations are complete on the OLT.

      • Run the display ont info command to query the ONT status to check whether the ONT is registered successfully.
      • Run the display service-port command to check whether the Internet access service flow is configured and whether the inner VLAN ID of the service flow is consistent with that in the data plan.
      • If a native VLAN is configured for the Ethernet port on the ONT, run the display ont port attribute command in the xPON board mode to check whether the native VLAN is correct.

    2. Check the upstream and downstream ports by checking the MAC address learning status.

      1. Run the display mac-address vlan command to check the MAC address learning status of the Internet service VLAN.
        • If the upstream port does not learn a MAC address, check the network connections between the upstream port and upper-layer devices and check the configurations of upper-layer devices.
        • If the downstream port does not learn a MAC address, check whether the ONT is activated, whether the PC is connected to the right port on the ONT, and whether the PC is working properly.
      2. Run the display ont-learned-mac command to check whether the ONT connecting to the PON port learned any MAC addresses.

        If not, check whether the ONT properly connects to the PC or home gateway (HGW).

  • Verify the voice service using call emulation.
    1. Run the ont emulational call command to configure a call emulation test.
      huawei(config)#test
huawei(config-test)#ont emulational call caller-port 0/1/0 1 1 telno 77730020
{ <cr>|caller-stop-time<K> }:

  Command:
          ont emulational call caller-port 0/1/0 1 1 telno 77730020
    2. The ONT outputs the call emulation result after the test is complete.
      huawei(config-test)#
  ----------------------------------------------------------------
  F/S/P                : 0/1/0
  ONT-ID               : 0
  ONT-POTSID           : 1
  Test type            : caller emulational call test
  Detected number      : 77730020
  Reported number      : 77730020
  Current status       : test end
  Test Result          : success
  ----------------------------------------------------------------
  • Troubleshooting methods for the voice service.
    1. Check whether configurations are complete on the OLT.

      • Run the display ont info command to query the ONT status to check whether the ONT is registered successfully.
      • Run the display service-port command to check whether the voice service flow is configured and whether the inner VLAN ID of the service flow is consistent with that in the data plan.

    2. Check the upstream and downstream ports by checking the MAC address learning status.

      Run the display mac-address vlan command to check the MAC address learning status of the voice service VLAN.
      • If the upstream port does not learn a MAC address, check the network connections between the upstream port and upper-layer devices and check the configurations of upper-layer devices.
      • If the downstream port does not learn a MAC address, check whether the ONT is activated and whether physical links are normal.
      • If both the upstream and downstream ports can learn the MAC address, record the MAC address of the ONT and log in to the service router (SR) to check whether an IP address is allocated to the MAC address.

    3. Check the registration status of the voice service.

      • You can run the display ont port state command on the OLT to query the call connection status on the POTS port. If Call State is RegisterFail or Connecting for a long time, check whether the voice configuration on the MGC/SIP server is consistent with that on the ONT.
      • If the ONT uses the H.248 protocol, you can run the display ont mg status command on the OLT to query the registration status of the MG interface that connects to the ONT. If MG Status is UnRegistered or Registering for a long time, check whether the voice configuration on the MGC/SIP server is consistent with that on the ONT.
      • You can query the registration status of the voice service on the ONT web page. If the query result shows that the registration fails or the voice service is in the registering state for a long time, check whether the voice configuration on the MGC/SIP server is consistent with that on the ONT.

  • Verify the multicast service using multicast emulation.
    1. Run the igmp static-join command to simulate a multicast user to order a multicast program.
      huawei(config)#btv
huawei(config-btv)#igmp static-join service-port 1 ip 224.1.1.10 vlan 1000
      NOTE:
      If the multicast program is obtained dynamically, igmp static-join can be executed successfully only when the range for obtaining the dynamic program is set.
    2. Run the display igmp user command to query the status of the multicast user.
      huawei(config-btv)#display igmp user service-port 1
  User                       : 0/1/0/1
  State                      : online
  Authentication             : no-auth
  Quick leave                : MAC-based
  IGMP flow ID               : 1
  Video flow ID              : 1
  Log switch                 : enable
  Bind profiles              : -
  IGMP version               : IGMP v3
  Current version            : IGMP v3
  Current IGMP IPv6 version  : IGMP IPv6 v2
  Available programs         : 8
  Global leave               : disable
  User max bandwidth         : no-limit
  Used bandwidth(kbps)       : 0
  Used bandwidth
  to max bandwidth(%)        : -
  Total video bandwidth      : -
  Mcast video bandwidth      : -
  Active program list
  ---------------------------------------------------------------------------
  Program name     VLAN  IP/MAC           State           Start time
  ---------------------------------------------------------------------------
  PROGRAM-5        1000  224.1.1.10       watching        2011-10-29
                                                          16:33:41+08:00
  ---------------------------------------------------------------------------
  Total: 1
    3. Run the display multicast flow-statistic command to query the real-time traffic of the multicast program.
      huawei(config-btv)#display multicast flow-statistic vlan 1000 ip 224.1.1.10
{ <cr>|sourceip<K> }:

  Command:
          display multicast flow-statistic vlan 1000 ip 224.1.1.10
  Command is being executed. Please wait...
  Multicast flow statistic result: 8736(kbps)